Support » Plugin: AMP » php 7 compatible?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Mohammad Jangda

    (@batmoo)

    I haven’t seen or heard of any php7 issues (and it’s running fine on production servers with php7). What errors did the compatibility checker report?

    WilliamTai

    (@williamtai)

    FILE: /wp-content/plugins/accelerated-mobile-pages/includes/options/redux-framework/inc/browser.php
    ——————————————————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————————————–
    113 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
    ——————————————————————————————————————————————–

    FILE: /wp-content/plugins/accelerated-mobile-pages/includes/options/redux-framework/inc/validation/preg_replace/validation_preg_replace.php
    ————————————————————————————————————————————————————————————
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————————————————————————————
    30 | ERROR | preg_replace() – /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0
    ————————————————————————————————————————————————————————————

    Plugin Author Mohammad Jangda

    (@batmoo)

    Looks like that’s for a different plugin. https://wordpress.org/plugins/amp/ does not use redux-framework.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘php 7 compatible?’ is closed to new replies.