Support » Plugin: Duplicate Post » PHP 7 compatibility

  • Resolved lisaleague

    (@lisaleague)


    I’m looking at updating to PHP 7 and ran this checker https://wordpress.org/plugins/php-compatibility-checker/ and found this warning.

    FILE: /wp-content/plugins/duplicate-post/duplicate-post-admin.php
    ———————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ———————————————————————————————–
    1 | WARNING | File has mixed line endings; this may cause incorrect results
    ———————————————————————————————–

    https://wordpress.org/plugins/duplicate-post/

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have got the same issue for PHP7.
    And can you please also check for compatibility of newest WP V4.6.1,
    thx.

    Plugin Author Lopo

    (@lopo)

    Hi,
    the warning should not have any consequence: it’s raised because the files have DOS newlines instead of Unix newlines, but correcting that and running the scan again gives no more warnings.
    I’ll make sure that’ll not happen in the next version.

    I’m also checking compatibility with 4.6.1, I’ll update the info very soon if I don’t release an update.

    Good to hear, thanks!

    Plugin Author Lopo

    (@lopo)

    Hi,
    the new 3.0.1 version is PHP 7 and WP 4.6.1 compatible.

    Sent a donation, thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘PHP 7 compatibility’ is closed to new replies.