Support » Plugin: Acunetix Secure WordPress » PHP 7 Compatibility

  • Joy

    (@joyously)


    I ran the PHP Compatibility Checker plugin https://wordpress.org/plugins/php-compatibility-checker/
    checking for PHP 7 compatibility and got this result for this plugin:

    FILE: wp-content/plugins/secure-wordpress/res/inc/SwpaInfo.php
    ------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ------------------------------------------------------------------------------------
     172 | WARNING | INI directive 'safe_mode' is deprecated since PHP 5.3 and removed since PHP 5.4.
    ------------------------------------------------------------------------------------
    
    FILE: wp-content/plugins/secure-wordpress/res/inc/SwpaUtil.php
    ------------------------------------------------------------------------------------
    FOUND 9 ERRORS AND 1 WARNING AFFECTING 9 LINES
    ------------------------------------------------------------------------------------
     225 | ERROR   | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0 - use mysqli instead.
     229 | ERROR   | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0 - use mysqli instead.
     235 | ERROR   | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0 - use mysqli instead.
     236 | ERROR   | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0 - use mysqli instead.
     275 | WARNING | Method name "SwpaUtil::__doBackup" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
     284 | ERROR   | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0 - use mysqli instead.
     285 | ERROR   | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0 - use mysqli instead.
     288 | ERROR   | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0 - use mysqli instead.
     288 | ERROR   | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0 - use mysqli instead.
     294 | ERROR   | Extension 'mysql_' is deprecated since PHP 5.5 and removed since PHP 7.0 - use mysqli instead.
    ------------------------------------------------------------------------------------
    
    FILE: wp-content/plugins/secure-wordpress/res/inc/SwpaSecurity.php
    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------
      41 | WARNING | Method name "SwpaSecurity::__hideFooterVersion" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
     719 | WARNING | Method name "SwpaSecurityHelper::__removeWpVersionFromLinks" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------
  • The topic ‘PHP 7 Compatibility’ is closed to new replies.