Support » Plugin: Category Posts in Custom Menu » PHP 7 compability?

  • Hi there,

    thanks for a great little useful plugin!

    Any chance it could be updated to work well with PHP7 too?

    I got this error report when running a compability check:

    FILE: wp-content/plugins/category-posts-in-custom-menu/cpcm-functions52.php
    ---------------------------------------------------------------------------------------------------
    FOUND 4 ERRORS AFFECTING 4 LINES
    ---------------------------------------------------------------------------------------------------
     26 | ERROR | preg_replace() - /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0
     31 | ERROR | preg_replace() - /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0
     38 | ERROR | preg_replace() - /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0
     43 | ERROR | preg_replace() - /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0
    ---------------------------------------------------------------------------------------------------
    
    FILE: wp-content/plugins/category-posts-in-custom-menu/category-posts-in-custom-menu.php
    ------------------------------------------------------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ------------------------------------------------------------------------------------------------------------------------------------------------------
     533 | WARNING | Method name "CPCM_Manager::__empty" is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ------------------------------------------------------------------------------------------------------------------------------------------------------
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Diana Koenraadt

    (@anaid)

    Hi Anders,

    I haven’t looked into that yet. Although I haven’t made a specific plan on when I will do that, I’ll address it soon and will mention it in the Changelog.

    Thanks for the heads-up.

    Kind regards,
    Diana

    sweet! Thanks

    Plugin Author Diana Koenraadt

    (@anaid)

    Hi Anders,

    I just revisited this today (yes, late, I know, sorry) and see now (heheh, woops) that the errors occur in file cpcm-functions52.php

    This file is *only* used for PHP 5.2 and lower. Otherwise, it is not ignored.

    What remains is a warning, I’ll fix usage of double underscores to get rid of that warning.

    Either way, you’re good to go for PHP 7.0!

    Kind regards,
    Diana

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘PHP 7 compability?’ is closed to new replies.