Support » Plugin: WooCommerce Collapsing Categories » PHP 7.2 compatibility

  • Carlos Longarela

    (@carloslongarela)


    Hi, can you change plugin code for compatibility with PHP 7.2?

    In woocommerce-collapsing-categories/includes/class-wcc-widget.php line 62 (end of file) change:

    add_action('widgets_init', create_function('', 'return register_widget("WCC_widget");') );

    to:

    add_action( 'widgets_init', function() { return register_widget( 'WCC_widget' ); } );

    Thanks in advance.

    Best regards.

Viewing 1 replies (of 1 total)
  • I was going to ask the same thing. I have the pro version and am getting a “Function create_function() is deprecated” using PHP 7.3.0.

    Thanks!

Viewing 1 replies (of 1 total)
  • The topic ‘PHP 7.2 compatibility’ is closed to new replies.