Support » Plugin: Cloudflare » PHP 7.2 compatibility

  • sergialarconrecio

    (@sergialarconrecio)


    For when the plugin will be compatible for PHP 7.2.X and be able to make the webs load faster not slow to have to use PHP 7.1.X or more recent versions of PHP, since the plugin Cloudflare gives errors if you use the latest version of PHP. PHP 7.2.X.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Are you getting incompatibility with 7.2? It seems fine for me. I tried the WPEngine PHP 7 compatibility checker but it doesn’t run on this plugin as it says it is too large…

    How did you determine the plugin was not 7.2 compatible? Thanks

    derekakelly

    (@derekakelly)

    I have tested this with php 7.0, 7.1, 7.2 & 7.3

    The first thing I noticed is that it breaks my list of plugins when using 7.1+, so i reverted back to 7.0

    I have started a thread on their github in hopes of getting their attention.

    https://github.com/cloudflare/Cloudflare-WordPress/issues/228

    Thanks Derek!

    Jarrod Whitley

    (@jarrodwhitley0518)

    It’s worrisome that the Cloudflare team is actively ignoring this issue.

    Here are the 7.2 incompatibility error/warnings I’m getting:

    FILE: /nas/content/live/mysite/wp-content/plugins/cloudflare/vendor/symfony/yaml/Parser.php
    ————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————–
    76 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    ————————————————————————————————–

    FILE: /nas/content/live/mysite/wp-content/plugins/cloudflare/vendor/symfony/yaml/Inline.php
    ————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————–
    55 | WARNING | INI directive ‘mbstring.func_overload’ is deprecated since PHP 7.2
    ————————————————————————————————–

    FILE: /nas/content/live/mysite/wp-content/plugins/cloudflare/vendor/cloudflare/cloudflare-plugin-backend/src/SecurityUtil.php
    ——————————————————————————————————————————————————
    FOUND 2 ERRORS AFFECTING 1 LINE
    ——————————————————————————————————————————————————
    16 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead
    16 | ERROR | Extension ‘mcrypt’ is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead
    ——————————————————————————————————————————————————

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @imakeinnernettes Please do not report topics unless they’re spam or abuse.

    Vincent

    (@imakeinnernettes)

    @jdembowski Understood. Actually clicked report by accident when clicking Favorite. New sensitive mouse.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    It happens. 😎

    I had also a blank page. I disabled Cloudflare plug-in, then activated it. I had to re-enter my credentials and now works as expected. I’m on PHP 7.2.

    Plugin is working fine for me on PHP 7.2 and 7.3

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘PHP 7.2 compatibility’ is closed to new replies.