Support » Plugin: All-in-One Event Calendar » PHP 7.2

  • Resolved dannyavilamedia

    (@dannyavilamedia)


    I’m working with WPEngine and just updated to PHP 7.2.

    This plugin caused a 500 error and WPEngine is saying it’s not compatible.

    Can I get some help please?

    Thanks!

    Danny

Viewing 1 replies (of 1 total)
  • Hi @dannyavilamedia

    The 500 error usually means file corruption, due to permissions errors.

    I suggest a manual reinstall. These instructions will preserve your current events:

    – Perform a complete back up of your database before proceeding further
    – Delete the file uninstall.php from the plugin directory that is currently on the server (found under /wp-content/plugins/all-in-one-event-calendar). Deleting this file ensures that when you uninstall the current version of the plugin, your event data and calendar settings will be preserved when you delete the plugin (don’t skip this step – it’s important!)
    – Deactivate the All-in-One Event Calendar using your WordPress Dashboard.
    – Delete the All-in-One Event Calendar using your WordPress Dashboard.
    – Database -> wp_options, click option_name to sort and delete everything with ai1ec_, this will delete plugin settings but events will remain in the database.
    – Now install the latest version.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.