WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Permissions and compat.php

[Resolved] Permissions and compat.php

  • Oh dear. I just tried to ‘harden’ my WP blog using the security tutorial on this site, and something has gone horribly wrong. I found myself suddenly unable to do anything at all, despite only having changed the said CHMOD permissions to 744. I now receive this error page:

    Warning: main(/…/…/…/…/wp-includes/compat.php) [function.main]: failed to open stream: Permission denied in /home/…/public_html/…/wp-settings.php on line 117

    Warning: main(/…/…/…/…/wp-includes/compat.php) [function.main]: failed to open stream: Permission denied in /home/…/public_html/…/wp-settings.php on line 117

    Fatal error: main() [function.require]: Failed opening required ‘/…/…/…/…/wp-includes/compat.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/…/public_html/…/wp-settings.php on line 117

    Line 117 in wp-settings.php being

    require (ABSPATH . WPINC . ‘/compat.php’);

    I’ve now been forced to put a 777 CHMOD on everything to see if it reverses the error. It hasn’t. I’m now unable to move within my admin, and get that error every time I try to do anything.

    Clearly I’ve made a big mistake but does anyone know how to remedy it?

    Huge thanks in advance…

    Lewis

Viewing 2 replies - 1 through 2 (of 2 total)
  • … and the blog no longer works at all.

    It’s still under construction so it’s not being viewed by anyone yet.

    Right, sorted… some files/folders in the wp-includes directory were set at 744.

    I’ll just have to be a bit more careful in the future…

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Permissions and compat.php’ is closed to new replies.
Skip to toolbar