Support » Plugin: WP Bulletin Board » permissions

  • Resolved iempoweru


    I have read the other threads and don’t see my issue being addressed. Thanks in advance for your time. I also love this plugin, can hardly wait to start using it!

    I have a membership site, with the following roles:
    visitor with read only on every item on the site
    free subscriber that also has contributor status
    and 3 paid subscriber roles that also have contributor status.

    I only want the 3 paid subscriber roles to have access to the forum

    I have gone to the role permissions page

    set admin and the 3 paid memberships to yes
    set the wordpress roles to no

    Each time I make changes I refresh the roles.

    In settings I enabled guest permissions

    Then I go into wpbb and set the permissions for a forum, which I copied to all of the other forums. In this one I give the desired permissions/role

    Then I tested each forum in each role. Everything works except for the free subscriber. They can see/write the forum.

    Can you tell from this description what I am doing incorrectly? Thanks in advance!

Viewing 1 replies (of 1 total)
  • Plugin Author codebycarter


    Hey iempoweru,

    If the permissions aren’t saving correctly when you create or edit a forum or subforum then please try from your admin dashboard -> WPBB -> Tools -> Refresh Roles.

    It should work if you don’t want your subscribers to view a forum, did you set any permissions for them at all? I’d try to uncheck all permissions for subscribers. Do your users have more than 1 role? Because it they do, if that other role has permission they will have permission.

    Also if you have denied a role access to a forum, they will still be able to see it and look inside the forum but they won’t be able to view or create any topics.

    Will be introducing a new permission in a future update so that you can stop permissions seeing / viewing inside a forum entirely.

    Please let me know if there’s anything else I can help you with 🙂


Viewing 1 replies (of 1 total)
  • The topic ‘permissions’ is closed to new replies.