Support » Networking WordPress » Permalinks resolving to /blog

  • I have three multisite installations. One is old, which I moved from one server to another. The other two are new and set up on two different servers. All three of them have the same issue.

    The permalinks resolve to /blog such as:

    http://ganeshdesignstudio.com/blog/sample-post/

    I cannot get rid of /blog no matter what I do

    I’ve tried going into Network Admin –> Sites –> Edit –> Settings –> Permalink Structure and removing what was there.

    Anyone?

Viewing 8 replies - 1 through 8 (of 8 total)
  • 1. Dashboard –> Pages –> Edit Page –> Edit Permalink
    2. Check Appearance –> Theme and check the Home page settings
    3. Appearance –> Menus

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    You’re using SubFolder installs of WP? That’s what you’re supposed to see on your main site.

    I don’t think I’m using SubFolder installs. (How would I determine this?)

    Every time I edit the site in Super Admin, the /blog/%postname%/ shows up after “permalink structure.” It might stay gone for awhile, but it always reappears and /blog remains in the main site’s permalink.

    I tried with mpmarino suggested with no luck.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Well. What’s an example URL of a subsite? If it’s domain.com/sitename then you’re using a Subfolder install. If it’s sitename.domain.com then it’s subdomains.

    It’s domain.com/sitename.

    but it’s the domain.com that has the /blog permalink I can’t remove.

    Any workaround the /blog issue?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    You are using subfolders 🙂 And domain.com having /blog/ in your permalinks is what, by default, you’re supposed to have.

    I’ve tried going into Network Admin –> Sites –> Edit –> Settings –> Permalink Structure and removing what was there.

    That’s how you do it HOWEVER. Should ever, at any time, refresh permalinks on the main site (by even going to visit that permailnk page), the blog comes back. This is not a bug. It’s in order to prevent name collisions between domain.com/postname and domain.com/blogname

    Interesting.

    Is there a work around to rename /blog?

    Or probably, I’ll need to change something in the portfolio.php or create a domain.com/portfolio subsite.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Generally if the Network Admin –> Sites –> Edit –> Settings –> Permalink Structure thing doesn’t work (because your permalinks refresh, which BTW happens via a lot of other plugins), then the best thing to do is keep the /blog/ call in there as is and either make a subsite for the custom name you need, use Custom Post Types, OR just redirect things to use /blog/.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Permalinks resolving to /blog’ is closed to new replies.