Support » Fixing WordPress » permalinks problem!

  • Hi there, i just installed wordpress and running my website “” with 60 subdomain but m unable to fix permalinks!
    whenever i put /%postname%/ post address seems ok but message come to my page not found! plz help?

    i m using 1 ftp account for all those subdomain and for home page as well.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Using only %postname%
    If using version 2.0 or greater, the following is no longer true as this has been changed.

    If you use postname as the only element in your permalinks to create a structure such as, the rewrite rules may make it impossible to access pages such as your stylesheet (which has a similar format) or the /wp-admin/ folder . It’s best to include some numeric data (e.g. the post ID or date) in the permalink to prevent this from happening. Additionally, WordPress v1.2.x requires the use of a date structure in order for some features, such as the calendar, to function properly. /%year%/%monthnum%/%day%/%postname%/ is always a good start.

    I personally have my doubts, so I use post-id/postname. See if that works better.

    so there is no solution of it? i want to make my pages in %postname% format, what to do now?

    My pages don’t have the ID in the permalink, just the posts.

    Are you refering to pages or posts? Do you have problems with both or just one of them?

    Posts should not start with post name, you should pick a number before post name, as date or post id. Doing otherwise will slow down things and possibly create db issues, not recommended. On the other hand, pages start with their names. That’s how WP figures quickly which one is a post and which one is a page.


    @vangrog Both (page and post)
    look i have made another one site in which have same wp files permalinks are working on that website but not working with , may be m guessing there is DB problem or may be not
    let me know what to do next?

    It’s on the same host?

    Check the .htaccess file on the blog directory of the host you’ve been experiencing problems with. It should have this code written:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    (“RewriteBase /” and if you are using it the blog in the root of the website; if it is a folder inside the website, write its path there, as “/blog/”, if the folder is named “blog”; in this case, change also: “RewriteRule . /blog/index.php”).

    If you dont see that code in the file, insert it manually and upload the file back to your blog directory. If you dont find any .htaccess file at all, create a text file, add the code above, upload to your blog directory and rename the file to “.htaccess”.

    If your host doesnt allow you to add .htaccess files, you’d have to use “almost pretty links” instead of real pretty ones.

    Example of an almost pretty link setting: /index.php/%post_id%/%postname%/ (it should start with “/index.php/”, the rest is up to you).


    now open website “” m getting an error

    If it does not work, sounds like your host does not allow it. So you would have to go for “almost pretty links”, as explained above.


    Ok, thnks for you help! may be the problem with my host.
    But why m unable to upload img in my post and pages too? what happens with images?

    My posts at my site are in separate categories, and have different post titles, of course. However, if you click from the homepage, the two posts will have the same permalink: the title of the first post. What should I do to correct this?

    I had the same issue: hundrets of pages, hundrets of posts (257/396) after two years of running a blog.

    When I started my site, all went OK, even I was using only /%postname%/ permalink structure. Posting and viewing the site was prompt.

    Everything went OK, publishing new pages/posts went smoothly.

    But after two years of publishing I was about to change content of bigger amount of pages and a problem appeared: when I was trying to save EDITED PAGE, after 30 seconds my server responded with 500 Internal Server Error. The issue appeared only when editing existing pages. Post editing and publishing of new pages and posts was smooth.

    When I tried to access Permalink settings page in admin backend, the page was loading like for 3 minutes or so…

    I changed the permalink structure from /%postname%/
    to /%post_id%/%postname%/ and suddently site appear to run as fast as when I started it 2 years ago.

    Page editing now works like charm.

    And at first I was blaiming my plugins 🙂

    …and the best stuff is that now I don’t need to modify anything, because if I use old URL’s, they work too!

    When I try to access old URL, it automagically swaps for example from to

    Thanks, Gangleri & vangrog 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘permalinks problem!’ is closed to new replies.