Support » Fixing WordPress » Permalinks not Working

  • Resolved yogesh2tech

    (@yogesh2tech)


    Hi,

    I am new to wordpress and trying to install it. Although wordpress site is working well but when I try to change permalinks from default to Month and Name or any other, page can not get displayed. Getting error message ” Oops! This link appears to be broken.”. My website is
    http://games.firebrand.co.in

    Pls help and suggest the same.

    Regards
    Yogesh

Viewing 10 replies - 1 through 10 (of 10 total)
  • Check the permalink again, make sure the customized data is accurate.

    Hi,

    Still Not working.

    This is my .htaccess file.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    #AllowOverride All
    ## uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule . index.php [L]

    Yogesh,

    Try to rename .htaccess to .htaccess1. Then access your admin part of wordpress -> turn permalinks off -> turn permalinks on again. New .htaccess file should be created automatically. Then access your blog again and permalinks should work fine then.

    If problem will persist, check whether mod_rewrite works on the server or not.

    Hi Akgroup,

    I did the the same but .htaccess file is not getting created automatically.

    esmi

    (@esmi)

    Forum Moderator

    Then you need to create an .htaccess file

    Hi ESMI,

    Can u pls tell me the syntax of .htaccess file that suit wordpress permalinks structure ?

    Pls help

    esmi

    (@esmi)

    Forum Moderator

    When you reset the permalinks, WP tells you exactly what to add to your .htaccess file.

    Hi esmi,

    Its not giving such message what to do in .htaccess file.

    esmi

    (@esmi)

    Forum Moderator

    Have you tried changing the permissions on the .htaccess file to 777?

    Hello Esmi,

    I have set the permission to 777. But still not resolving the problem.
    Can you take my pc on team viewer to see the problem.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Permalinks not Working’ is closed to new replies.