Support » Fixing WordPress » Permalink Settings

  • Hello,

    When I change my Permalink Settings in Dashboard:

    1.) My settings have always been to “post name” For example, my home page used to be rsoldiers.com/home and my blog was rsoldiers.com/blog respectively.

    2.) Now for some reason when I type in those URL’s, I get this instead:

    *Typing: rsoldiers.com/home gets a 404 page not found error.
    The actual home page URL is as follows (https://rsoldiers.com/?v=7516fd43adaa)

    blog URL is now: (https://rsoldiers.com/blog/?v=7516fd43adaa)

    3.) I’d like to know how to remove the: ?v=7516fd43adaa and revert everything back to the way it should be.

    Any clever solution will work for me. I’m a newbie, and thank you in advance for any help and insights you can offer me.

    Thank you,

    Jonny

    p.s. I have read the “Using Permalinks” documentation in WordPress. I am still unable to decipher my predicament.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The appended ?v=7516fd43adaa is not a permalinks addition.
    You must have some other plugin or function adding this onto the URL.

    Effectively with a URL, everything after a ? is the query string – it is used to pass variables into a page. The page name/URL is the still same but some plugin appears to be adding a query string.

    Look in the source => View Source – you will see that your URL’s are fine – there is something adding the query string after the page is rendered (it will be something using jQuery)

    Thank you Shannon! I really appreciate your response.

    Can anyone else expand on possible solutions? Is there an easy way to remove the query string without harming the URL?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Permalink Settings’ is closed to new replies.