Support » Fixing WordPress » Permalink Settings

  • I looked around and all over and couldnt find a solution so i decided to ask here… ok, enough with the intro

    i made the non-seo-friendly mistake of choosing the default permalink settings – i want to change it to Month & Name but when i do, none of the links work. Now im sure it has to do with the htaccess file. I guess my question is, where is it located? – i cant seem to find one within the wordpress dir on my host. Any recommendations or am i doing something wrong? – feedback appreciated!

Viewing 4 replies - 1 through 4 (of 4 total)
  • nevermind! – i got it – there WASNT one – so i made a new txt file – uploaded it to host in root directory – renamed it “.htaccess” and pasted this code in it:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Im having the same problem, however when I edit my .htaccess to read the above, it still doesnt work.

    nish4x:

    make sure there are no other .htaccess on your host – i had a duplicate that was mixing it up as well

    Yeah i had to create one, and while it updated the link format, the content from those links isnt showing.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Permalink Settings’ is closed to new replies.