Support » Plugin: Gutenberg » permalink edit is missing

  • Resolved efstraatios

    (@efstraatios)


    In the page builder, I cannot find the edit button to change the permalink.

    And since I use the Greek language, the edit button is a must have

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Marius L. J.

    (@clorith)

    Hi,

    It’s a bit hard to find right now (we’re looking into ways to make it more discoverable), but if you click in the title field (at the top of your post), it should show up above the title.

    It took me 2 days and some research to discover how to edit the permalink, not exactly intuitive but at least it seems this is now being worked on.

    Additionally, when you first click on the title block, it presents the option to ‘change permalinks’. Clicking on this invites you to change your site permalink structure, not what you’re looking to achieve and not something you want as part of the editor.

    Only after saving the draft are you given the option to ‘edit’. Note: you have to actually click the edit button before you can edit, clicking on the link takes you to a preview instead.

    Its a good example of what is bad about Gutenberg. How much simpler and user-friendly it is to just click on the link and edit it.

    The problem with how it is currently implemented is it won’t show up until you save a draft first. Then by clicking on title you’ll get the permalink window.

    I just posted on this, not seeing the present post. This is definitely a hidden feature, not something that i’d ever have found without being told where to look. I’m wondering what was wrong with where it is in pre-GB WordPress?

    Also, for the developers, if you invoke this feature when there’s a message bar at the top of the page that bar partially covers the permalink and completely covers the edit button (desktop, about 1200 px wide).

    Also, when i first clicked on the edit (permalink) button, the whole thing disappeared and i had to click the title again. Ah… now i see that it seems to be intended to be hidden as soon as you focus anywhere else, although i didn’t think that i had done that.

    And finally – this is quite problematic – when i finally get the permalink to edit it is URL encoded, so i cannot actually edit it but instead have to type or paste in the whole permalink (it may work passably with Roman characters but not in other alphabets like Cyrillic, Chinese, etc.)

    I’ve spent 20 minutes reading moderator posts and trying to implement them to no avail. After I publish the page I click the title at the top in Editor and I see a new box that gives me the option to Change permalinks which takes me to the permalinks settings page …/wp-admin/options-permalink.php
    How do I actually change an individual page permalink?

    @michaelgli – Here is what “Marius L. J.” said about the button to change permalink:

    Hi,

    It’s a bit hard to find right now (we’re looking into ways to make it more discoverable), but if you click in the title field (at the top of your post), it should show up above the title.

    Thanks Roy, I read the same post from several people, several times, but it is unrelated to what I see. It’s hard to describe a screen in words but I’ll try again.

    When I click the title field at the top of the post what I see is:

    link symbol (copy the permalink)
    permalink URL (takes me to page preview)
    Change Permalinks button (goes to Permalink Settings …wp-admin/options-permalink.php)

    There is no edit button.

    Michael

    Moderator Marius L. J.

    (@clorith)

    Hi all,

    This is another users 4+ month old topic at this point, in light of that I am closing it, if you are seeking support I encourage you to create your own topic, this way we don’t spam other users with email notifications.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘permalink edit is missing’ is closed to new replies.