Support » Plugin: NP Quote Request WooCommerce » Payment Method Disabled

  • Hello,

    When I activate RFQ plugin, my payment method plugin (a local payment method similar to Paypal) stops showing in the checkout page, even if there is no product with RFQ enabled in the cart. When I deactivate RFQ, it goes back to normal.

    Any guess of what might be happening?

    I have Woocommerce 2.6.0 and your latest plugin installed.

    Thank you in advance,

    Marcel.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Neah Plugins

    (@gplsaver)

    Is the checkout option set to RFQ in
    woo-rfq-setting->general ?

    I think you need to set your woo-rfq setting to normal checkout.

    Hello,

    Thank you for your fast reply!

    This option is already chosen (Normal Checkout). I believe there might be a conflict between both plugins. And this payment method is widely used in Brazil. It would be nice if we could find out what is causing this problem.

    Thank you for your time,

    Marcel.

    Plugin Author Neah Plugins

    (@gplsaver)

    Does it work with other payment plugins activated and the specific local one inactive?
    Does it work it you set “always show all prices” checkbox to yes in woo-rfq setting

    • This reply was modified 2 years, 11 months ago by Neah Plugins.

    Sorry for the delay…

    Both plugins work fine when activated. The only problem is that when Woo-RFQ is active, it somehow hides the option of the local payment (Pagseguro plugin), it actually shows for frames of seconds, and disappears right away. And sometimes, after pressing F5 (refreshing the checkout page), the payment plugin option shows again and works fine. But when Woo-RFQ is off, none of these things happen, the payment option shows just fine during checkout.

    Your test did work though: when “always show all prices for normal checkout” is enabled, the payment plugin shows fine in the checkout page. But I don´t want products for quote to show price and buy button, only the RFQ button. Is there a work around for this?

    Thanks a lot for you kind help!

    Regards,

    Marcel.

    Plugin Author Neah Plugins

    (@gplsaver)

    Can you put a link to a test site where i can see the css using the browser. I might be able to suggest something

    The website is live, actually. This is a link to a test product that is marked with RFQ:

    http://www.pdrtech.com.br/produto/teste/

    As you can see, it shows both price and buy button, which we did not want to.

    If you have any suggestions, please let me know.

    Thanks a lot for the help,

    Marcel.

    Plugin Author Neah Plugins

    (@gplsaver)

    Can you turn the prices off so we can get the problem. Thanks. I think it is a css issue.

    I just did. Thank you!

    Plugin Author Neah Plugins

    (@gplsaver)

    Is this problem resolved?

    Hello Neah,

    Thanks for asking, but unfortunately not yet. After you said it could be a CSS issue, I tried to fix it myself but with no success. I don´t know if you were able to check if there was anything weird that could be hiding this payment method. Any insights would be very helpful!

    I wouldn´t mind at all paying for a pro version or donating to this plugin, for all the help and attention you gave us so far. But I really need to get this plugin working on 2 different sites that use this same payment method (pagseguro), that is widely used here in Brazil as well.

    Thanks for your time anyway!

    Best,

    Marcel.

    • This reply was modified 2 years, 10 months ago by web40.
    Plugin Author Neah Plugins

    (@gplsaver)

    If you want to email me at contact@neahplugins.com, I have an idea that may work for you.

    Ok Neah, I just emailed you!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Payment Method Disabled’ is closed to new replies.