Support » Plugin: Quick Page/Post Redirect Plugin » parse errors

  • Getting the following errors on one site:

    on activate:
    Parse error: syntax error, unexpected T_STRING, expecting ‘,’ or ‘;’ in /home/applewoo/public_html/wp-content/plugins/quick-pagepost-redirect-plugin/page_post_redirect_plugin.php on line 224

    on edit page or create and publish new page:

    Warning: parse_url(http://) [function.parse-url]: Unable to parse URL in /home/applewoo/public_html/wp-content/plugins/quick-pagepost-redirect-plugin/page_post_redirect_plugin.php on line 1157

    Warning: Cannot modify header information – headers already sent by (output started at /home/applewoo/public_html/wp-content/plugins/quick-pagepost-redirect-plugin/page_post_redirect_plugin.php:1157) in /home/applewoo/public_html/wp-admin/post.php on line 233

    Warning: Cannot modify header information – headers already sent by (output started at /home/applewoo/public_html/wp-content/plugins/quick-pagepost-redirect-plugin/page_post_redirect_plugin.php:1157) in /home/applewoo/public_html/wp-includes/pluggable.php on line 896

    Tried removing and reinstalling the plugin.

    Thanks for any help.

    https://wordpress.org/plugins/quick-pagepost-redirect-plugin/

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have the same problem, i still wait for one answer !

    Getting the parse errors on all of my sites now.

    I wonder if the developer is going to respond, or if I should replace this plugin?

    I go back to version 5.0.3, and i wait the next version, i can’t work like that .

    I’m also getting parse errors…

    two things happening, the plugins page in the administration dashboard is very slow to load now.

    Whenever I update a page or post – it gives me a blank white page, with the following parse errors

    Warning: parse_url(http://) [function.parse-url]: Unable to parse URL in /home/ovcweb/public_html/onevoiceinc.com/wp-content/plugins/quick-pagepost-redirect-plugin/page_post_redirect_plugin.php on line 1157
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/ovcweb/public_html/onevoiceinc.com/wp-content/plugins/quick-pagepost-redirect-plugin/page_post_redirect_plugin.php:1157) in /home/ovcweb/public_html/onevoiceinc.com/wp-admin/post.php on line 233
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/ovcweb/public_html/onevoiceinc.com/wp-content/plugins/quick-pagepost-redirect-plugin/page_post_redirect_plugin.php:1157) in /home/ovcweb/public_html/onevoiceinc.com/wp-includes/pluggable.php on line 896

    any insight on fixing this would be great – I don’t see any errors on my actual pages for visitors, which is good – but it could be somewhere I don’t see…

    Thank you

    I can confirm I am also getting this bug with 5.0.5, while on my development site (Hostgator). My live sites are fine.

    I, too, had this problem, and I determined that (in my case) the url being given to the appip_parseURI() method was an empty string, which resulted in parse_url() attempting to parse “http://” and bombing out.

    My solution was to edit page_post_redirect_plugin.php and insert the following line of code at line 1148 (the first executable line of appip_parseURI())…

    if( $url == '' ){ return array( 'url' => $url ); }

    My usage of this plugin is very limited (a single redirect), but this at least allowed me to edit posts/pages again without getting these errors!

    [ The appip_parseURI() method is only called from one place in the class, and on its return, the ‘url’ element of the returned array is assigned to a “my_meta_data” array, escaped as a raw url, and then tested as being equal to http[s]:// or an empty string … at which point it is deemed non-applicable and the post meta is cleared down. ]

    Shawn

    (@shawnwyatt-1)

    Be careful on the down-grade, see this:

    Vulnerabilities in WordPress older than 3.8.2, Twitget Plugin and Quick Page Post Redirect Plugin.

    Where:

    Plugin Vulnerability: Quick Page/Post Redirect Plugin contains a CSRF and stored XSS vulnerability. Vulnerability ID is: CVE-2014-2598 (not yet published)

    What to do: Upgrade to version 5.0.5 or later. Author is aware of vulnerability and has fixed it.

    Shawn

    (@shawnwyatt-1)

    Oh…and I get the same error after I post. Not sure if I want to edit the plugin per wizzud, but that’s awesome you found a work-around.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘parse errors’ is closed to new replies.