Support » Plugin: PHP Code for posts » Parse Error Syntax error

  • I keep getting this error. I’m not sure if it is due to the plugin or not. I’m trying to run a query from my from my remote DB. Every time I run my PHP script.

    Parse error: syntax error, unexpected end of file in /home/ubuntu/workspace/wp-content/plugins/php-code-for-posts/Classes/Shortcode.php(81) : eval()'d code on line 86 Call Stack: 0.0004 242632 1. {main}() /home/ubuntu/workspace/index.php:0 0.0004 243080 2. require('/home/ubuntu/workspace/wp-blog-header.php') /home/ubuntu/workspace/index.php:17 0.1187 5400304 3. require_once('/home/ubuntu/workspace/wp-includes/template-loader.php') /home/ubuntu/workspace/wp-blog-header.php:19 0.1231 5414800 4. include('/home/ubuntu/workspace/wp-content/themes/responsive-brix/single.php') /home/ubuntu/workspace/wp-includes/template-loader.php:75 0.1945 5856208 5. hoot_get_content_template() /home/ubuntu/workspace/wp-content/themes/responsive-brix/single.php:45 0.1959 5859096 6. include('/home/ubuntu/workspace/wp-content/themes/responsive-brix/template-parts/content.php') /home/ubuntu/workspace/wp-content/themes/responsive-brix/hoot/includes/template.php:73 0.1991 5869528 7. the_content() /home/ubuntu/workspace/wp-content/themes/responsive-brix/template-parts/content.php:46 0.1992 5870048 8. apply_filters() /home/ubuntu/workspace/wp-includes/post-template.php:240 0.2002 5873632 9. call_user_func_array:{/home/ubuntu/workspace/wp-includes/plugin.php:235}() /home/ubuntu/workspace/wp-includes/plugin.php:235 0.2002 5873664 10. do_shortcode() /home/ubuntu/workspace/wp-includes/plugin.php:235 0.2003 5876296 11. preg_replace_callback() /home/ubuntu/workspace/wp-includes/shortcodes.php:223 0.2004 5878088 12. do_shortcode_tag() /home/ubuntu/workspace/wp-includes/shortcodes.php:223 0.2004 5878672 13. call_user_func:{/home/ubuntu/workspace/wp-includes/shortcodes.php:326}() /home/ubuntu/workspace/wp-includes/shortcodes.php:326 0.2004 5878832 14. PhpCodeForPosts_Shortcode::handle_shortcode() /home/ubuntu/workspace/wp-includes/shortcodes.php:326 0.2008 5886440 15. PhpCodeForPosts_Shortcode::do_shortcode() /home/ubuntu/workspace/wp-content/plugins/php-code-for-posts/Classes/Shortcode.php:38

    https://wordpress.org/plugins/php-code-for-posts/

  • The topic ‘Parse Error Syntax error’ is closed to new replies.