WordPress.org

Support

Support » Plugins and Hacks » Parse error eval code on line 1

Parse error eval code on line 1

  • Hello, wonderful Allen! Okay, so…can’t figure it out. I’m including all of my logic.
    Totally stumped. The error is being thrown a lot.

    ‘PHP Parse error: syntax error, unexpected ‘!’ in /home1/suzytest/public_html/wp-content/plugins/widget-logic/widget_logic.php(284) : eval()’d code on line 1′

    Widget #1: ‘is_front_page()’

    Widget #2: ‘in_category( 139) || is_search && !is_front_page () && !is_page (31)’

    Widget #3: ‘is_page( 31 )’

    Any ideas? Sorry if it’s something ridic. Thank you so much for this great plugin.

    http://wordpress.org/extend/plugins/widget-logic/

Viewing 1 replies (of 1 total)
  • Plugin Author alanft

    @alanft

    It’s likely the spaces between the function name and the brackets, so should look more like

    !is_page(31)

    instead of

    !is_page (31)

    and so on

Viewing 1 replies (of 1 total)
  • The topic ‘Parse error eval code on line 1’ is closed to new replies.