Support » Plugin: WooCommerce PDF Invoices » Parse error after Update 2.0.0

Viewing 12 replies - 1 through 12 (of 12 total)
  • Same here. I’m rolling back for the minute.

    I’ve found my problem… I was using this version.
    http://www.woothemes.com/products/pdf-invoices/

    and without realising I automatically upgraded to…
    https://wordpress.org/plugins/woocommerce-pdf-invoices/

    They’re unrelated plugins with the same name. It’s be nice if the WP plugin directory had SKU codes or something like that for plugins so that sort of thing wouldn’t happen.

    Plugin Author Bas Elbers

    (@baaaaas)

    I’m looking into it.
    You could try to delete, download and reactivate version 2.0.0.

    Thanks theApe: same with me. Wrong Plugin-Auto-Update…

    Plugin Author Bas Elbers

    (@baaaaas)

    It’s really strange WordPress only looks at the name of the plugin. theApe thanks!!

    Wel, try out this plugin. 🙂 It’s free and has a lot more features like sending invoices to cloud storage. If you have some request for new features, let me know and I will add it.

    I’ve removed old version of plugin “woocommerce-pdf-invoices” v 1.1.2,

    downloaded new zip version 2.0.0 – reinstall plugin but still get:

    Parse error: syntax error, unexpected ‘[‘ in /wp-content/plugins/woocommerce-pdf-invoices/admin/classes/woocommerce-pdf-invoices.php on line 276

    ???

    Any ideas why?

    Regards,
    Jan

    Plugin Author Bas Elbers

    (@baaaaas)

    Could you remove the array [‘class=”…”‘] on line 276 and try again? I don’t know anymore what the name of the class is called. I don’t get the error my self so it’s hard to debug.

    I had the same problem, but i found the solution: you have to make sure you’re on PHP >= 5.4

    The shorthand method for arrays is only supported in PHP >= 5.4, and my server was still using 5.3. After upgrading to PHP 5.5, the error was gone.

    Bas, to improve compatibility i guess you should not use the shorthand code.

    P.S.: great work on the new version of the plugin!

    Plugin Author Bas Elbers

    (@baaaaas)

    Thanks Lisa for finding the solution. 😀 I will update the plugin as soon as possible! Could you be so kind to give me a 5 star review? If you have any feature requests, please let me know. 🙂

    I’ve noticed these shorthand codes too, but for me it is impossible to update php. Is there any chance that you correct this baas, as i think a lot of people will have troubles with this…and it’s a shame for this really GOOD plugin not to be compatible with php under 5.4.

    If i am correct it is just a replacement of [‘xy’] to array(‘xy’)..or am i wrong and it is a lot more work involved?

    regards,
    Jan

    Plugin Author Bas Elbers

    (@baaaaas)

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Parse error after Update 2.0.0’ is closed to new replies.