Support » Plugin: WooCommerce PDF Invoices & Packing Slips » Parse error after update

  • Resolved LRA21

    (@slysoft)



    At the beginning of may, my site crashed after plugin update.
    What’s the fix for this issue?

    Parse error: syntax error, unexpected ‘&&’ (T_BOOLEAN_AND), expecting ‘)’ in

    …………./wp-content/plugins/woocommerce-pdf-invoices-packing-slips/includes/compatibility/class-wcpdf-compatibility-third-party-plugins.php on line 210

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Ewout

    (@pomegranate)

    Hi! This was fixed in 2.1.8, are you perhaps still on 2.1.7?

    I don’t know right now, because can’t see the login admin page.
    Plugins are updated automatically.
    How can I find this?

    Plugin Author Ewout

    (@pomegranate)

    ah, that sounds like that would be 2.1.7, I’m sorry to hear the update broke your site.

    I strongly recommend disabling automatic plugin updates (not just for our plugin but for any plugin on a business critical production site)! This issue affected sites with older PHP versions and the bug didn’t surface in testing. Even with very thorough testing regimes these kind of things can happen, especially with an almost infinite number of possible configurations of sites with different plugins/themes.

    Here are 2 simple steps to fix the issue:

    1. Log into your site with FTP or cpanel, remove the woocommerce-pdf-invoices-packing-slips folder in wp-content/plugins.
    2. reinstall the latest version of the plugin via WP

    Ewout

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Parse error after update’ is closed to new replies.