• Resolved johnjohnston

    (@johnjohnston)


    Hi,
    I just updated the plugin and all the pages in my blog went blank.
    PHP Version 5.3.19

    I turned on WP_DEBUG and got this:
    Parse error: syntax error, unexpected ‘[‘ in /Customer Web Sites/johnjohnston/public_html/blog/wp-content/plugins/indieweb-post-kinds/includes/Mf2/Parser.php on line 356

    deleted the plugin via ftp and the site came back.

    Cheers

    John

    https://wordpress.org/plugins/indieweb-post-kinds/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author David Shanske

    (@dshanske)

    I updated the Parser, which is a third-party library. But I don’t get this error on any of my sites. Will investigate tonight and address.

    Plugin Author David Shanske

    (@dshanske)

    Found the problem, the latest changes to the Parser are using short array notation that only came in in 5.4.

    Will try to pursue upstream to get to minimum 5.3 as advertised and manually address tonight.

    Plugin Author David Shanske

    (@dshanske)

    Manually removed the code in question, opened an issue in the php-mf2 parser library, pushed Version 2.3.6 which should be PHP 5.3 compatible.

    Thread Starter johnjohnston

    (@johnjohnston)

    Hi David,
    Thanks, I’ve reinstalled the plugin and everything appears to be fine on my site now. Thanks for the quick fix.

    Cheers

    John

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Parse error’ is closed to new replies.