Support » Theme: Elara » Parent menu Item

  • First I would like to say that you’ve made a beautiful theme, thank you.

    I just finished building a site with several pages with 4 menu items that have submenus under them. 3 of the 4 parent menu titles link directly to pages but when I check them in my browser the links are stripped and replaced with a “#”. I haven’t ever run into this before so I’m guessing this is by design in your theme – but can I override this?
    Thanks again.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello, JustBruno.

    Thank you for contacting us and for using our theme. We appreciate it and the fact that you like it as well. 🙂

    Now, in order to override that behaviour, you’ll need to make one small change in one theme file.
    Please navigate to /elara/parts/navigation-header.php and change the line 25

    'depth' => 2, so that instead of 2 you put 3 or 4 until all of your menu levels work.

    Hope this helps.

    Kind regards.

    Theme Author lyrathemes

    (@lyrathemes)

    @justbruno Thanks for trying out Elara, we appreciate it.

    I think @siniplyrathemes may have misunderstood the issue here. I think you’re referring to the main parent menu items where they open on hover but on click, there is no link and they actually link to “#”.

    This is by design, but I have made a note of this so we can make adjustments to allow you to link to an actual URL in the next update.

    Stay tuned!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Parent menu Item’ is closed to new replies.