Support » Plugin: Stripe For WooCommerce » Paramater Missing

  • Resolved sablednah

    (@sablednah)


    The payment option doesn’t show in checkout. The API is connected – and the test button works.

    The following error appears in Stripe when I load the checkout page.

    400 ERR POST /v1/payment_methods

    parameter_missing – type
    Missing required param: type.

    And the following Response Body:

    {
      "error": {
        "code": "parameter_missing",
        "doc_url": "https://stripe.com/docs/error-codes/parameter-missing",
        "message": "Missing required param: type.",
        "param": "type",
        "type": "invalid_request_error"
      }
    }

    I’ve checked as as far as I can see everything is connected properly.

    Whats going wrong? How do I fix?

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author mr.clayton

    (@mrclayton)

    @sablednah,

    You’re using a currency switcher plugin. You need to register the payment gateways with the currency switcher so that the Stripe payment gateways show on your checkout page.

    Kind Regards,

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.