WordPress.org

Support

Support » How-To and Troubleshooting » paging not working?

paging not working?

  • It’s not clear to me how the paging option is supposed to work. In the Reading Options page, I’ve set 10 Posts paged, but there would appear to be no UI for actually changing the page.
    In searching this site, I’ve found this code:
    <?php posts_nav_link() ?>
    and I’ve tried pasting it into the index.php file in various locations. It does cause paging to work, though it puts the paging link between each and every post, which I really don’t want.
    What is the “posts paged” option for if not for paging, and, how do you get it to work?

Viewing 7 replies - 1 through 7 (of 7 total)
  • You’ve probably set the Paging option correctly in the Options section. You just need to find the right place for the posts_nav_link code in your index.php. Try to do it out “The Loop” and you’ll get it in the right place.
    Regards

    Thanks Cypher.
    > You’ve probably set the Paging option correctly in the Options section. You just need to find the right place for the posts_nav_link code in your index.php. Try to do it out “The Loop” and you’ll get it in the right place.
    After some trial and effort, putting it outside of any number of loops, it would appear to finally be working!
    Now to make it look better instead of the default typeface, alignment, etc…
    Thanks.

    OK, so the code above is working and my CSS now styles it in a way I’m at least temporarily happy with. However,
    <?php posts_nav_link() ?>
    generates only a ‘next page’ / ‘previous page’. Is there a tweak for adding “first page” / “last page” as well?

    hello, I’m desperately seeking this solution! where exactly did you put the code? (This seems a bit secret.)
    Felmon

    just outside the loop would work:
    <?php endif; ?> this marks the end of the WP Loop.

    sorry guys,
    but there is no way to get the paging displayed.
    i put in <?php posts_nav_link() ?> directly after the loop.
    in the outputcode there is nothing rendered. strange.
    some advices?
    thanks

    Options|Reading|Show X posts_paged

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘paging not working?’ is closed to new replies.
Skip to toolbar