WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Option for selecting plugins to disallow?

[Resolved] Option for selecting plugins to disallow?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Matthew
    Moderator

    @kidsguide

    I would be very interested in adding this but I don’t know how.

    For now you can use this code.

    function stop_plugin_update( $value ) {
     unset( $value->response['smooth-slider/smooth-slider.php'] );
     return $value;
    }
    add_filter( 'site_transient_update_plugins', 'stop_plugin_update' );

    Put it in your function.php file for your theme.

    http://www.softpoint.in/disable-update-notification-single-plugin-wordpress.html

    Thanks for trying my plugin!

    Plugin Author Matthew
    Moderator

    @kidsguide

    Did the code above work?

    Plugin Author Matthew
    Moderator

    @kidsguide

    I just added a setting to this plugin to disable plugins individually (version 3.4.0). Hopefully it works!

    jonburr
    Participant

    @jonburr

    Thanks for adding the single-plugin disable option.
    How does it work? – that is, how do you select the individual plugin update to disable?

    Tim Bare
    Participant

    @tbare

    Wow – apparently I wasn’t getting the updates – thanks for the replies. I’ll install the plugin on a dev site and try it out. 🙂

    jonburr
    Participant

    @jonburr

    Ah – I found a plugin to do it… “block specific plugin updates

    Plugin Author Matthew
    Moderator

    @kidsguide

    Thanks for downloading it.

    To block a plugin update, go to the settings page and check the option “Disable Plugins Individually”. Then go to the “Plugin Page” and by the update notice (in screenshot 7) you will see a notice that will say “Block updates for this plugin”. Click on it and then the updates for that plugin will be disabled.

    I will look at that plugin and maybe add some of the features in it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Option for selecting plugins to disallow?’ is closed to new replies.