Support » Plugin: Image optimization service by Optimole » Optimole Causing issue With OG Meta Tags

  • Resolved Lokender Kumar

    (@lokenderkumar)


    Hi,
    I deactivated the Optimole plugin and blog post featured image are not showing up while sharing them on Social Media.
    I am getting this error on Sharing Debugger: Provided og:image URL, https://blogginggenie.com/wp-content/uploads/2019/03/Wordpress-SEO.jpg could not be processed as an image because it has an invalid content type.
    But once I reactivate the plugin featured images start showing up.
    Another thing is that after reactivating the Optimole plugin WordPress pages are displaying sidebar images as featured image.
    Regards,
    Lokender

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author optimole

    (@optimole)

    Hello Kumar,

    I’m not seeing Optimole active on your site right now? Moreover, the image you are reporting is not optimized thru Optimole, it’s a source image from your site.

    Do you use any caching mechanism on your site? Make sure to clear that after you have connected the plugin.

    Lokender Kumar

    (@lokenderkumar)

    Hi,
    I was not pointing out to that Image.That was just an error shown by Facebook Debugger tool.
    What I am trying to say is, When I keep Optimole activate featured image show up on Facebook. Here is a screen shot link: https://pasteboard.co/IbAOK2o.png
    Whenever I deactivate the Optimole Plugin Featured Image disappears.
    Here is a Screen shot just after uninstalling the plugin: https://pasteboard.co/IbAQuF1.png

    Plugin Author optimole

    (@optimole)

    Hello @lokenderkumar,

    I think I know now what you are saying. Have you deleted the image recently from your site? This might be the reason why this is happening.

    After we process the image first time we cache the original source for 1 month. If you want to remove that image from the og:image tag you can replace it or remove with something else.

    Let me know if this makes sense to you.

    Lokender Kumar

    (@lokenderkumar)

    I want to get rid of this plugin without breaking the og:image. What should I do?

    Plugin Author optimole

    (@optimole)

    Hello Kumar,

    We don’t add or alter any kind of og tags in your site, neither og:image nor anything similar.

    The reason why it still shows with our plugin ON is that the image is cached on our server.

    You can remove that image from the SEO plugin that you use I guess, for more info, you can contact their support team.

    Let me know if this makes sense to you, I’m not sure how can I help you more from my side.

    Lokender Kumar

    (@lokenderkumar)

    Thanks for your support

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.