• Resolved andreu

    (@andreu)


    Hi,

    After enabling the plugin a message “WooCommerce Gateway PayPal Express Checkout requires OpenSSL >= 1.0.1 to be installed on your server” appears.

    I have a basic RapidSSL certificate on my server and I’m working through HTTPS. Is that not enough?

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    Hi there,

    > I have a basic RapidSSL certificate on my server and I’m working through HTTPS. Is that not enough?

    This will be based on your server’s settings. If you take a look at WooCommerce > Settings > System Stats, then scroll down to Server Environment and then cURL Version, you’ll see what version is installed on your server. If this isn’t at least 1.0.1, you’ll need to contact your host to upgrade.

    Thank you, I have 0.9.8 so I’ll contact with my server admins to see what we can do with it.

    Best,

    Plugin Contributor Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    Please do update the thread when you know more and mark it as resolved if your question has been answered.

    Thanks!

    mr86

    (@mr86)

    Hi,
    I’m receiving the same error on my wordpress backend.

    WooCommerce Gateway PayPal Express Checkout requires OpenSSL >= 1.0.1 to be installed on your server

    Woocommerce > System Stats shows
    cURL version: 7.48.0, OpenSSL/1.0.1e

    I’m hosting this on godaddy shared hosting account. and have purchased ssl from them.

    On my test environment hosting on 1&1 i don’t have this issue.

    Consequently, order placed through paypal are stuck at “Pending-payment”

    Any help and guidance is greatly appreciated.

    mr86

    (@mr86)

    Hi,
    To anyone having similar issue, using paypal Shared web hosting account.
    login to your host using SSH.
    run command curl -i https://tlstest.paypal.com
    Should return a 200 status if test passes.
    mine returned Unknown SSL protocol error in connection to tlstest.paypal.com:443

    Solution:
    Godaddy’s Shared WebHosting only support version 5.3 & 5.4. PHP 5.6 or above is required for to resolve this error.
    Godaddy upgraded my plan to Cpanel hosting which supports PHP 5.6 (still not 7 like most other hosts), but it seem to have resolved the issue.

    Hope this helps someone.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘OpenSSL required’ is closed to new replies.