Support » Plugin: Duplicator - WordPress Migration Plugin » Open_Basedir Directory Error – SOLVED

  • Resolved Company 50

    (@co50)


    We’ve been struggling with our restores lately. We kept encountering the open_basedir error trying to restore any site. We worked with our hosting (we have a VPS) to try to resolve it but nothing worked. We kept having them do manual migrations for us.

    Finally we found the issue and I’m posting this more or less FYI in case it’s a bug or unintended functionality: When there is an .htaccess file in the public_html of a site, the script starts looking for an .htaccess outside of the public_html folder for some reason and because our open_basedir restrictions do not allow php scripts executing/running outside of the public_html folder, it fails. Removing the .htaccess file from the public_html root allows the script to run. This was never an issue in the past but is the case across the board for the last few months. Maybe the script could advise on this similar to how it does if you leave wp-config.php in the root and do a restore.

    • This topic was modified 4 months ago by  Company 50.
Viewing 1 replies (of 1 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @co50

    We haven’t really seen this on any of our testings, but it might be environment specific. If you want to submit a support ticket for this issue we can have a closer look at your setup if you want, so we can see how to properly root cause the issue. Please provide a link to this thread when submitting the ticket if you choose to go that route, Otherwise, we can try to look at adding additional logic to try and intercept the issue in one of the upcoming releases.

    Thanks~

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.