• Resolved generosus

    (@generosus)


    Good Day,

    So this Just happened:

    Upon refreshing our Analytify widget, we started to get an OpenSSL error inside our widget.

    The error reads:

    Oops!
    OpenSSL SSL_read: error:0A000126:SSL routines::unexpected eof while reading, errno 0
    Don't worry, This error message is only visible to Administrators.

    Details: https://prnt.sc/RO9mSoFFrCYR

    Tried a few things to help fix the issue. No dice.

    From reading other support forum topics, it appears this is a new plugin issue. Perhaps you guys are conducting live tests for your upcoming GA4 plugin update.

    Kindly review and provide a fix.

    Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Jo Larsen

    (@jolana99)

    Same thing happened to me. Only download the plugin yesterday – all was fine now no longer working – same error

    mattspaur

    (@mattspaur)

    The pinned message at the top of this forum indicates that this is a problem with a new release of cURL (https://curl.se/). My Analytify diagnostic file contains “cURL: Enabled (7.85.0 OpenSSL/3.0.8)”. The most recent cURL version is 7.88. I would like to know whether Analytify will update to work with newer versions of cURL, if my hosting company installing a future version of cURL will fix this problem automatically, or if there’s something else I need to do. Or, maybe it’s time to drop Analytify for something else.

    Thread Starter generosus

    (@generosus)

    Hey @mattspaur,

    Yeah, that’s probably what’s causing the issue. It looks like cURL updates have caused issues with Analytify in the past (look at the pinned post in this support forum).

    cURL 7.88.0 (stable) was released yesterday (February 15, 2023) and OpenSSL 3.0.8 was released recently (February 7, 2023). Our host (SiteGround) is using cURL 7.85.0 and OpenSSL 3.08. So perhaps upgrading the server to cURL 7.88.0 might fix the issue.

    We’ll reach our to SiteGround to get a reading from them and find out if they have any plans to update cURL from 7.85.0 to 7.88.0 in the near future.

    Still, we need input (and possibly a fix) from the developers of Analytify 🙂

    PS: I wouldn’t drop Analytify. It’s a great plugin and good things are in work (such as GA4 and other cool updates). Stay tuned.

    Cheerio!

    Thread Starter generosus

    (@generosus)

    Update:

    We received feedback from SiteGround Support.

    SiteGround, indeed, upgraded their servers last night to OpenSSL 3.0.8 which, most likely, explains why we’re having this issue.

    SiteGround recommends that the developers upgrade their plugin to ensure compliance with OpenSSL 3. Once completed, this issue should be resolved.

    Also, SiteGround plans to update their servers to cURL 7.88.0, but do not have an ETA defined yet.

    Plugin Developer(s):

    Help appreciated. Kindly provide a fix at your earliest opportunity.

    Thank you!

    Jo Larsen

    (@jolana99)

    I am SiteGround too so that would help

    Thread Starter generosus

    (@generosus)

    Resolved (Temporary Solution):

    After a good cup of coffee and some research, we found a quick, simple solution for this issue. Drum roll please.

    1. Go to /wp-content/plugins/wp-analytify/lib/Google/IO/Curl.php
    2. Line 79: Replace curl_setopt($curl, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_1_0); with curl_setopt($curl, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_1_1);
    3. Save the file, clear all cache, enjoy!

    Note:

    Best to use curl_setopt($curl, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_2_0); or curl_setopt($curl, CURLOPT_HTTP_VERSION, CURL_HTTP_VERSION_3);

    We’re using VERSION_3 (fastest, safest option) with no issues.

    Reference: https://curl.se/libcurl/c/CURLOPT_HTTP_VERSION.html

    Looking forward to the developer(s) of this plugin fixing this issue (permanently).

    Cheers!

    mattspaur

    (@mattspaur)

    I’m also a SiteGround user for multiple sites and clients. I’ve verified the fix on one site and will implement on others until Analytify updates their code. Thank you for your generous smarts.

    cornertune

    (@cornertune)

    @generosus Thank you for the fix!

    Plugin Author Adnan

    (@hiddenpearls)

    @generosus Thank you so much for helping users in my absence.

    I just sent release with an update of curl version to 2_0

    Note: We are working on GA4 compatibility and It is around the corner. Stay tuned.

    Thread Starter generosus

    (@generosus)

    Hi Adnan,

    My pleasure!

    Would it be possible to re-release your plugin using VERSION_3?

    It is the safest, fastest connectivity option at this time and is backwards compatible.

    Details can be found in the reference link provided. We’re using it now with no issues. Also, data seems to collect better and faster with it.

    Thank you!

    Thread Starter generosus

    (@generosus)

    Update:

    Please disregard our previous recommendation to use VERSION_3. We have learned that VERSION_3 is not yet compatible with PHP 8.X.

    This is what happens when using VERSION_3 and PHP 8.X: https://prnt.sc/sw_Gtl8fN4Sk

    So, we’re back to using the plugin’s current version, VERSION_2_0, which is compatible with PHP 8.X.

    Apologies for any confusion.

    Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘OpenSSL Error Detected’ is closed to new replies.