Support » Plugin: Gravity Forms + Typeform Addon » One error issue is showing

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor jepser

    (@jepser)

    Did you add your Typeform token and the form has fields?

    Yep correct that was all site, the plugin worked fine on a local dev site. The issue only showed on a live site.

    Plugin Contributor jepser

    (@jepser)

    Could you please tell me if you have PHP >5.3 in the production server?

    @jepser.

    Yep correct PHP 5.5.24.

    Plugin Contributor jepser

    (@jepser)

    Finally (I want to check the must common issues), do you have file_get_contents available?

    Same issue on a local VVV site, with only Gravity Forms and Gravity Forms + Typeform Addon as the active plugins.

    Notice: Undefined property: stdClass::$id in /srv/www/wordpress-default/wp-content/plugins/typeform-addon-for-gravity-forms/tf-gf.php on line 102

    Notice: Undefined property: stdClass::$_links in /srv/www/wordpress-default/wp-content/plugins/typeform-addon-for-gravity-forms/tf-gf.php on line 103

    Warning: Invalid argument supplied for foreach() in /srv/www/wordpress-default/wp-content/plugins/typeform-addon-for-gravity-forms/tf-gf.php on line 84

    So it shows when you enable Enable Typeform render in the Typeform Settings.

    Plugin Contributor jepser

    (@jepser)

    Hi Luke
    There are several scenarios:

    • file_get_contents not supported
    • PHP <5.3
    • No fields in the form
    • No API Key added
    • No Typeform render enabled
    • Fields not supported

    I added a new update where it ignores not supported fields, please update when available and tell me 🙂

    @jepser

    That fixed the issue.

    Plugin Contributor jepser

    (@jepser)

    Thanks awesome 🙂 good to know that!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘One error issue is showing’ is closed to new replies.