Support » Plugin: W3 Total Cache » Object Cache Bug

  • serdarwork

    (@serdarwork)


    Hi,

    I’m using WordPress multisite and my web server is Nginx. I just updated W3TC plugin yesterday. (V0.10.0)

    Before the update, the load speed of my website was 100x faster. I also see connection timeout errors after the update. Because the W3TC object cache feature is not working well.

    Today, I just disabled Object cache on the W3TC panel. My website is very fast again.

    I’m 100% sure these are not a web server or network issues. I tested my other multi-sites which has W3TC installed. Same loading issues there. Even I saw 504 errors when Object cache is enabled.

    I can make a screen record if you need.
    Best regards.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @serdarwork,

    Do you have both DB cache and object cache enabled? If so does the issue persist if you disable DB cache and leave Object cache enabled?
    Have you tried restarting your nginx?
    If the issue persists, please try to completely remove and re-install W3 Total Cache.
    as there is a chance that the plugin update process failed at some point:
    1. Purge Cache
    2. Deactivate and Delete Plugin
    3. Check .htaccess File (make backup)
    W3TC will create many directives in .htaccess file to control the caching behavior. Each section will start and end with comments like “#BEGIN W3TC Page Cache core” and “#END W3TC Page Cache core”.
    Ensure that no residual entries are leftover in your .htaccess file after deleting the plugin.
    4. Delete wp-content files and folders
    – cache folder
    – w3tc-config folder
    – object-cache.php File (if exists)
    – advanced-cache.php (if exists)
    – dbcache.php (if exists)
    – upgrade folder
    5. Delete Cached Files from CDN (if using CDN)
    Besides deleting all the relevant files, if you use CDN then ensure to purge the cached content from your CDN. This is necessary when you enabled minify option in W3TC settings. You should delete the minified and combined scripts and CSS files from your CDN server to avoid the site breaking on the browser.
    6. Re-install W3 Total Cache.

    serdarwork

    (@serdarwork)

    Hi @vmarko

    Thank you for the support, I really appreciate it. I implemented exactly what you said in the previous reply. However, I’m experiencing the same issue. It didn’t solve my problem.

    Anyway, I recorded a video about the issue. Can you please check it:
    https://yadi.sk/i/rvp09F94eTCS6w

    – My website is using the latest PHP (7.3)
    – I’m a system administrator and I can say that my server is configured very well.
    – The Object cache issue is not related to any theme or any plugin. Because I enabled the Object cache on my other multi-sites. The same problem is there.

    Let me know your feedback, please.
    Best regards.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @serdarwor,

    Are you using Memcached by any chance?

    serdarwork

    (@serdarwork)

    Yes @vmarko , I installed Memcached and PHP7.3-Memcached extension also. Memcached is working well.

    Ekran-Resmi-2019-09-11-16.56.44.png

    microonline

    (@microonline)

    I have the same problem, the server is up to date and it was working fine.

    It is more back to the previous version and it works, the problem is w3tc and its cache of objects in the new version.

    serdarwork

    (@serdarwork)

    @microonline https://github.com/W3EDGE/w3-total-cache/commit/3833a672ae076794f6de7ce5ed2fccf3291ba51e

    that fixed my issue. Try it, please.

    @vmarko Should I enable both database cache and object cache? Or enable the object cache only?

    Best regards.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @serdarwork,

    Glad to know the issue is resolved There is a new release 0.10.1 and the fix is included.
    It is advisable not to use both DB cache and Object Cache. Enabling Object Cache without DB cache is the best for most use cases.

    serdarwork

    (@serdarwork)

    @vmarko Once again thank you very much for all your help and response! King regards. 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this review.