Support » Plugin: Advanced Custom Fields: Table Field » Notice: Undefined index: use_caption

  • Resolved nickbasham

    (@nickbasham)


    Since updating to the v1.2.6, I’m running into the following error whenever I use a conditional statement with get_field on a table field to see if it exists:

    Notice: Undefined index: use_caption in [site]/wp-content/plugins/advanced-custom-fields-table-field/acf-table-v5.php on line 481
    H

    I’m assuming this is just a bug introduced with the added support for captions, but let me know if that’s not the case and there’s something I’m doing wrong on my end.

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Johann Heyne

    (@jonua)

    Hi,

    Sorry for the delay. The PHP error indicates, that you are using the table field plugin version 1.3.0 which introduces the caption option. This version is not released yet and is for testing purpose. However, I could not reproduce this error. The missing index ‘use_caption ‘ should be there by the default_value parameter of the function acf_render_field_setting(). Maybe, there is/was a bug in the ACF plugin or I miss something. Do you use the latest ACF plugin version and does the issue still exists?

    Cheers
    Johann

    afwebdev

    (@afwebdev)

    I just updated to 1.3.0 and am receiving the same error notices:

    Undefined index: use_caption in {site}/wp-content/plugins/advanced-custom-fields-table-field/acf-table-v5.php on line 481

    I’m running WordPress 5.1, ACF Pro 5.7.12.

    Plugin Author Johann Heyne

    (@jonua)

    The new version 1.3.1 should fix that error.

    Cheers,
    Johann

    afwebdev

    (@afwebdev)

    It looks like that did the trick – thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Notice: Undefined index: use_caption’ is closed to new replies.