Support » Plugin: Easy HTTPS Redirection » Not Redirecting

  • Resolved briannie

    (@briannie)


    I have the same problem on two different Managed WordPress sites and both are on 4.9.7. One address is shown above and the other is harrystebbing.com

    If I enter the address with or without www the address reverts to thedomain.com and shows as not secure. Similarly if I precede the address with http://

    Only if I enter the address with https:// does it show as secure. This applies to using Firefox, Chrome and Edge.

    On the plugin settings page all three boxes are checked and for the whole site.

    Can you assist me please?

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, have you set up an SSL certificate correctly in your site? The following is mentioned in the description of this plugin.

    Only use this plugin if you have installed SSL certificate on your site and HTTPS is working correctly

    Kind regards

    briannie

    (@briannie)

    I believe it is correctly set up. The host is 1&1 and they say it is set up. As I mentioned earlier if I prefix the address with https://, then it shows as secure but otherwise the address shows as unsecure.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, what URL address have you entered in the following fields located in Settings -> General?

    WordPress Address (URL)
    Site Address (URL)

    briannie

    (@briannie)

    Both fields have:

    https://elitebeautysawston.com

    Both are greyed out but I presume that is normal.

    • This reply was modified 1 year ago by  briannie.
    Plugin Support mbrsolution

    (@mbrsolution)

    Is your .htaccess file also modified when you enable this plugin? For example do you see the following entries?

    # BEGIN HTTPS Redirection Plugin
    # END HTTPS Redirection Plugin

    briannie

    (@briannie)

    You are now getting into an area where I am very uncomfortable. I suppose the answer is I don’t even know how to find this file let alone amend it.

    briannie

    (@briannie)

    OK I found it and have downloaded it to a txt file but can’t see how to attach it in order to send it to you (which I would like to do just to be sure it’s the right file) but as far as I can see those lines to not appear in the file.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, what you can do is simply copy and paste here what is in between the following two lines.

    # BEGIN HTTPS Redirection Plugin
    # END HTTPS Redirection Plugin

    Can you also share what settings you have enabled in the plugin.

    Thank you

    briannie

    (@briannie)

    Herewith the settings:
    Enable automatic redirection to the “HTTPS” Ticked

    Apply HTTPS redirection on: The whole domain selected

    Force resources to use HTTPS URL Ticked

    ==================================================================
    This is the .htaccess file content:

    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE text/cache-manifest
    AddOutputFilterByType DEFLATE text/javascript
    AddOutputFilterByType DEFLATE text/vcard
    AddOutputFilterByType DEFLATE text/vnd.rim.location.xloc
    AddOutputFilterByType DEFLATE text/vtt
    AddOutputFilterByType DEFLATE text/x-component
    AddOutputFilterByType DEFLATE text/x-cross-domain-policy
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE application/json
    AddOutputFilterByType DEFLATE application/ld+json
    AddOutputFilterByType DEFLATE application/atom+xml
    AddOutputFilterByType DEFLATE application/manifest+json
    AddOutputFilterByType DEFLATE application/rdf+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/schema+json
    AddOutputFilterByType DEFLATE application/vnd.geo+json
    AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
    AddOutputFilterByType DEFLATE application/x-font-ttf
    AddOutputFilterByType DEFLATE application/x-javascript
    AddOutputFilterByType DEFLATE application/x-web-app-manifest+json
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE font/eot
    AddOutputFilterByType DEFLATE font/opentype
    AddOutputFilterByType DEFLATE image/bmp
    AddOutputFilterByType DEFLATE image/svg+xml
    AddOutputFilterByType DEFLATE image/vnd.microsoft.icon
    AddOutputFilterByType DEFLATE image/x-icon
    </IfModule>

    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType text/css A2419200
    ExpiresByType text/x-component A2419200
    ExpiresByType application/x-javascript A2419200
    ExpiresByType application/javascript A2419200
    ExpiresByType text/javascript A2419200
    ExpiresByType text/x-js A2419200
    ExpiresByType text/html A3600
    ExpiresByType text/richtext A3600
    ExpiresByType image/svg+xml A3600
    ExpiresByType text/plain A3600
    ExpiresByType text/xsd A3600
    ExpiresByType text/xsl A3600
    ExpiresByType text/xml A3600
    ExpiresByType video/asf A2419200
    ExpiresByType video/avi A2419200
    ExpiresByType image/bmp A2419200
    ExpiresByType application/java A2419200
    ExpiresByType video/divx A2419200
    ExpiresByType application/msword A2419200
    ExpiresByType application/vnd.ms-fontobject A2419200
    ExpiresByType application/x-msdownload A2419200
    ExpiresByType image/gif A2419200
    ExpiresByType application/x-gzip A2419200
    ExpiresByType image/x-icon A2419200
    ExpiresByType image/jpeg A2419200
    ExpiresByType application/json A2419200
    ExpiresByType application/vnd.ms-access A2419200
    ExpiresByType audio/midi A2419200
    ExpiresByType video/quicktime A2419200
    ExpiresByType audio/mpeg A2419200
    ExpiresByType video/mp4 A2419200
    ExpiresByType video/mpeg A2419200
    ExpiresByType application/vnd.ms-project A2419200
    ExpiresByType application/x-font-otf A2419200
    ExpiresByType application/vnd.ms-opentype A2419200
    ExpiresByType application/vnd.oasis.opendocument.database A2419200
    ExpiresByType application/vnd.oasis.opendocument.chart A2419200
    ExpiresByType application/vnd.oasis.opendocument.formula A2419200
    ExpiresByType application/vnd.oasis.opendocument.graphics A2419200
    ExpiresByType application/vnd.oasis.opendocument.presentation A2419200
    ExpiresByType application/vnd.oasis.opendocument.spreadsheet A2419200
    ExpiresByType application/vnd.oasis.opendocument.text A2419200
    ExpiresByType audio/ogg A2419200
    ExpiresByType application/pdf A2419200
    ExpiresByType image/png A2419200
    ExpiresByType application/vnd.ms-powerpoint A2419200
    ExpiresByType audio/x-realaudio A2419200
    ExpiresByType image/svg+xml A2419200
    ExpiresByType application/x-shockwave-flash A2419200
    ExpiresByType application/x-tar A2419200
    ExpiresByType image/tiff A2419200
    ExpiresByType application/x-font-ttf A2419200
    ExpiresByType application/vnd.ms-opentype A2419200
    ExpiresByType audio/wav A2419200
    ExpiresByType audio/wma A2419200
    ExpiresByType application/vnd.ms-write A2419200
    ExpiresByType application/font-woff A2419200
    ExpiresByType application/vnd.ms-excel A2419200
    ExpiresByType application/zip A2419200
    </IfModule>

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    AddHandler x-mapp-php5.5 .php

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, I don’t see the following two entries.

    # BEGIN HTTPS Redirection Plugin
    # END HTTPS Redirection Plugin

    When I enable this plugin in my test site I see the following code.

    # BEGIN HTTPS Redirection Plugin
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{SERVER_PORT} !^443$
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>
    # END HTTPS Redirection Plugin

    What PHP version is your server running?

    I think the plugin is not writing to your .htaccess file. Try the following, deactivate and delete the plugin. Install a fresh copy and enable the same settings. Then check the .htaccess file and make sure you see something similar to what I mentioned above.

    Thank you

    briannie

    (@briannie)

    The PHP version is 7.2

    I have deactivated and deleted the plugin and then installed a fresh copy. I have ticked the two check boxes and enabled the radio button for the whole site.

    I rechecked the .htaccess file and there is no change. The desired code is still not showing in the file and the site address only shows as secure if I type in https:// otherwise it shows as insecure on FF, Chrome & Edge.

    Thank you for your support but is it time to admit defeat?

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, from what you describe above is letting me know that the plugin is not writing to your .htaccess file. That is why it is not working. I suspect that your .htaccess file might be corrupted or there might be something else not allowing the plugin to write to the .htaccess file.

    There is a few things you could try out. You could re save the permalink settings in WordPress, to see if that recreates your .htaccess file. Or make a copy of the .htaccess file or rename the file. Delete the current one, then save the permalink settings in WordPress, that will create a new .htaccess file. If that works, then try again to enable this plugin and save the settings. Once that is done, check again to make sure that this plugin has written to the .htaccess file similar lines like the ones I mentioned above.

    If it does not create a new .htaccess file, then you need to create one yourself and copy back the entries you copied above or if you renamed the file, then rename it back to .htaccess.

    If none of the above works, then please speak to your host and find out why this plugin is not writing to the .htaccess file.

    Let me know how you go.

    Kind regards

    briannie

    (@briannie)

    @mbrsolution very many thanks for working with me on this but the above is really all very complex. I’ve solved the problem now by deleting your plugin and activating “JSM Force HTTP to HTTPS” which has worked perfectly.

    I have used it before and it is excellent but your plugin was recommended by the registrar host 1&1.

    I guess it just didn’t work out this time but thanks again for your assistance which I’m fully aware is you giving your time for free.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Not Redirecting’ is closed to new replies.