Support » Theme: MesoColumn » not logged users can not post comments

  • Resolved markandweather

    (@markandweather)



    I recently noticed a problem that may have occurred at the time of making small changes to the theme configuration or other corrections.

    I wanted even users who have not logged in to be able to comment any posts that I would later moderate. In the Discussion Settings I have checked that the users do not need to be registered to comment.
    In fact, under each post there is a dialog window for not logged in users in which they can write a comment, but there is no button to send it (SUBMIT).
    Example: http://gminaslesin.futurehost.pl/sport/drugie-miejsce-dla-slesinskiej-zalogi-jachtu-pol-135-slesin-pl/

    There is only the text “This site uses Akismet to reduce spam.” Learn how your comment data is processed. ”

    How to fix it?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Theme Author Richie KS

    (@rkcorp)

    not sure, i do see the button tho, ‘Opublikuj komentarz’

    and i can leave a comment…just submit one for test..

    markandweather

    (@markandweather)

    Yes. I accepted your comment and it’s okay, but it’s weird, because when I enter as not logged in user I do not have the ‘post a comment’ button.

    You can see below:

    The text is cropped as if everything was not displayed. Can it be related to the malfunction of Akismet?

    Theme Author Richie KS

    (@rkcorp)

    not sure if this the case, but you will need to click the textarea for the section on name, website, email and submit button to appeared. is this it?

    markandweather

    (@markandweather)

    I changed in Settings in Discussion section to force entering by an user his name and e-mail. And when I am not logged in, I re-fresh a post twice and I start writing a comment the rest of the form pops up and finally I can submit it but this is very inconvenient and not intuitive to open twice articles to be able to comment it. It looks as if not entire content of the comment module were loaded the first time.

    “This site uses” is next to the dialog window and much below the rest of this message “Akismet to reduce spam. Learn how your comment data is processed..”.

    I try to show it in the below link:
    http://gminaslesin.futurehost.pl/wp-content/uploads/2018/08/Schowek-1.jpg
    but I am not sure you can see it.

    Theme Author Richie KS

    (@rkcorp)

    what browser you’re using?

    markandweather

    (@markandweather)

    The issue occurs both in the Mozilla Firefox and Google Chrome browser. Also while watching website on my mobile phone. I opened my website on another computer and I saw the same problem in the Opera browser.

    Theme Author Richie KS

    (@rkcorp)

    previously i can comment and when click the textarea, it show the meta form.

    now nothing, the textarea just won’t expand to show comment form.

    no clue why, it work previously and now don’t.

    however the js console show error with sdk.js, related to facebook. i think.

    markandweather

    (@markandweather)

    So what do you suggest correct with sdk.js file?

    Theme Author Richie KS

    (@rkcorp)

    now its working again. odd…

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.