Support » Plugin: WP Feed Post Thumbnail » Not adding anything…

  • Clicknathan

    (@clicknathan)



    Tried refreshing permalinks, saving settings on the General settings page you’ve added the two checkboxes to, nothing makes a difference. No post thumbnail in the feeds…

    Update! And then it started working!

    I’m guessing this may have had something to do with either my hosting’s caching or possibly even just my own browser cache. Works like a dream, thank you!

    • This topic was modified 2 years ago by  Clicknathan. Reason: Updated to reflect how very wrong I was
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Silvan Hagen

    (@neverything)

    Hi there and thank you for your feedback.

    Please have a look at the reply on this support ticket which I assume is the same issue you are having: https://wordpress.org/support/topic/not-seeing-image-thumbnails-in-feed-after-plugin-install/#post-7244147

    If this is the case, please update your rating or if not, open a support ticket and we will gladly help you out.

    Plugin Contributor Silvan Hagen

    (@neverything)

    @clicknathan: Thanks for changing your review. Let me know if you need any additional help with the plugin.

    Clicknathan

    (@clicknathan)

    Thank you Silvan! And sorry for being so quick to post earlier.

    Any way to force the plugin to always add a certain thumbnail size (like ‘thumbnail’ or ‘medium’) by chance?

    Plugin Contributor Silvan Hagen

    (@neverything)

    @clicknathan yes you can, we have two filters available for this:

    Check out the filters on Github. You will have to have something like the following in your code:

    <?php
    
    // Filters the size on media:content tag (defaults to full)
    add_filter( 'wp_feed_post_thumbnail_image_size_full', function( $size ) {
    	return 'large'; // return any registered image size
    }, 10, 1 );
    
    // Filters the size on the media:thumbnail tag (defaults to thumbnail)
    add_filter( 'wp_feed_post_thumbnail_image_size_thumbnail', function( $size ) {
    	return 'medium'; // return any registered image size
    }, 10, 1 );
    • This reply was modified 2 years ago by  Silvan Hagen. Reason: typo
    Clicknathan

    (@clicknathan)

    Beautiful, thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Not adding anything…’ is closed to new replies.