Support » Installing WordPress » No paragraph breaks in comments

  • rbmark

    (@rbmark)


    I’ve read other questions about comments and line breaks and I don’t have any smilie plug-ins.

    After moving my blog from .com to .org the comments on my posts have no paragraph breaks though they do when I look at them from the editor side.

    And comments on my pages do have breaks so I don’t know what’s going on there.

    Help?

    Thanks,
    Mark

Viewing 5 replies - 1 through 5 (of 5 total)
  • moshu

    (@moshu)

    If you switch to the default or classic theme – does the “error” persist? If no, work on your theme’s stylesheet.

    I’m having sort of the same problem. There are no paragraph breaks in any of the comments. This problem exists only in the theme I’m using so I’m sure it’s in the stylesheet, but I can’t find where to make the correction– nor do I know how to edit the css to fix it.

    Here is all the code I can find for comments, if it’s any help:

    ol#commentlist {
    list-style:none;
    margin:15px 0 0;
    padding:0;
    }

    .commentname {
    color:#444444;
    }

    .commentname a {
    color:#3399cc;
    font:110% “Trebuchet MS”, “Lucida Grande”, verdana, helvetica, arial, sans-serif;
    text-decoration:underline;
    }

    .commenttext {
    background-color:#f8f8f8;
    min-height:90px;
    }

    * html .commenttext {
    height:90px;
    overflow:visible;
    }

    .commentp {
    padding:20px 12px 10px 10px;
    }

    .commenttext p {
    margin:0 0 10px;
    padding:0;
    }

    #commentblock ol li {
    margin-bottom:30px;
    }

    #commentblock {
    margin-left:4px;
    }

    #commentsform p {
    margin-bottom:5px;
    margin-top:5px;
    }

    Can you give me any suggestions? My Web site is at http://streettalkblog.com

    Too bad your template doesn’t use any of those…
    Check your source code to see that the comments’ text is in a div class=”content” – so you need to define the paragraph’s margins for that class:

    .content p {
    margin: 20px 0;
    }

    Note. It’s a mess because you also have a div ID with the same name. Complain to the theme author.

    Thanks, moshu. I did contact the theme author (the theme is Tarsier Paradise, coded by Wicked WP) but got no response.

    For future reference, in case anyone else ever has this problem, I finally figured it out and it turned out to be so very basic: The author left no space between “comment” and “p” in the code, as follows.

    .commentp {
    padding:20px 12px 10px 10px;
    }

    I made this change:

    .comment p {
    padding:20px 12px 10px 10px;
    }

    and then adjusted the padding to suit me. Paragraphs at last!

    moshu,

    Thanks from me, too! I inherited a theme which didn’t account for the padding-bottom in the comment.p

    Great catch, and HOORAH for WP’s round B funding! Woo hoo!

    Thanks,

    Tim (will-work-for-stock-options) Jamz.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘No paragraph breaks in comments’ is closed to new replies.