Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Nextgen Gallery causes WSOD

  • Dear WordPress Community,

    I have an installation of WordPress with Nextgen Gallery Plugin, which causes a WSOD on hosting environment.

    I am sure Nextgen causes the error, because when i deactivate it manually (moving the plugin/nextgen directory somewhere else) the WSOD is gone.

    On my local environment everything works fine, so i think maybe a library or something Nextgen depends on is missing.

    The Server is running on Debian, with Apache2, PHP 5.4.4, (mySql Ver 14.14 Distrib 5.5.35)

    Apache error.log

    [DATE] [error] [client xx.xxx.xx.xxx] PHP Notice:  Undefined index: post_type in $path/wp-content/themes/simplenbright/functions.php on line 33
    [DATE] [error] [client xx.xxx.xx.xxx] PHP Notice:  Use of undefined constant portfolio - assumed 'portfolio' in $path/wp-content/themes/simplenbright/admin/inc/wphooks.php on line 92
    [DATE] [error] [client xx.xxx.xx.xxx] PHP Notice:  Undefined variable: image in $path/wp-content/themes/simplenbright/homepage-slider.php on line 20
    [DATE] [error] [client xx.xxx.xx.xxx] PHP Notice:  Undefined variable: image in $path/wp-content/themes/simplenbright/homepage-slider.php on line 20
    [DATE] [error] [client xx.xxx.xx.xxx] PHP Notice:  Undefined variable: image in $path/wp-content/themes/simplenbright/homepage-slider.php on line 20
    [DATE] [error] [client xx.xxx.xx.xxx] PHP Strict Standards:  Declaration of C_MVC_View::define() should be compatible with C_Component::define($context = false) in $path/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/mvc/class.mvc_view.php on line 30
    [DATE] [error] [client xx.xxx.xx.xxx] PHP Strict Standards:  Declaration of C_MVC_View::initialize() should be compatible with C_Component::initialize() in $path/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/mvc/class.mvc_view.php on line 30
    [DATE] [error] [client xx.xxx.xx.xxx] PHP Strict Standards:  Declaration of C_DataMapper_Driver_Base::define() should be compatible with C_Component::define($context = false) in $path/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/datamapper/class.datamapper_driver_base.php on line 741
    [DATE] [error] [client xx.xxx.xx.xxx] PHP Strict Standards:  Declaration of C_DataMapper_Model::__set() should be compatible with & ExtensibleObject::__set($property, $value) in $path/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/datamapper/class.datamapper_model.php on line 135
    [DATE] [error] [client xx.xxx.xx.xxx] PHP Strict Standards:  Declaration of C_Lightbox_Library_Mapper::define() should be compatible with C_Component::define($context = false) in $path/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/class.lightbox_library_mapper.php on line 45

    Thank you for any advice,
    dudeness

    https://wordpress.org/plugins/nextgen-gallery/

Viewing 1 replies (of 1 total)
  • Plugin Author photocrati

    (@photocrati)

    @dudeness – Although this issue may appear when NextGEN Gallery is active, the “Strict Standards” messages do not indicate anything that would take down a site. I would look at the theme issues in that error_log …

    … also, have you tried temporarily deactivating all plugins and switching to a default WordPress Twenty series theme then re-activating NextGEN Gallery?

    – Cais.

Viewing 1 replies (of 1 total)
  • The topic ‘Nextgen Gallery causes WSOD’ is closed to new replies.