Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Nextgen Column Issue on Mobile

  • I’ve been using Nextgen for years now and for a while been conscious that it’s not rendering well on my mobile. Each of the gallery pages is set up as 30 images per page across 3 columns. When viewing it on my mobile the gallery comes out as having 2 images on one line and then one image on the next and so on.

    Could anyone give some advice please. Thanks.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support gabyimagely

    (@gabyimagely)

    Hello @delta-skies

    Apologies, would you mind sharing your gallery shortcode here?
    Would you mind testing on a separated page the same gallery using our Basic Thumbnail Gallery display?
    Please, keep us posted, we are happy to help!

    Hi @gabyimagely,

    Thanks for the reply

    By gallery shortcode do you mean the id? In which case this particular one is “1”.

    I’ve just created a test page using the Basic Thumbnail Gallery display and the same happens

    • This reply was modified 1 month, 1 week ago by  Delta Skies.
    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @delta-skies

    Using the Classic Editor, your shortcode will be available at:
    https://drive.google.com/file/d/1_z1OSMU01CqzHJnxS80j2HmArp4JQFCD/view?usp=sharing

    Using Gutenberg, your shortcode will be available at:
    https://drive.google.com/file/d/1ZUT_GrVTIwfgtSyyzPNN4zIvbDUqhGSw/view?usp=sharing

    Please, keep us posted.
    We are happy to help!

    Delta Skies

    (@delta-skies)

    Hi @gabyimagely,

    Here we go…..

    [nggallery id=1 template=caption images=999]

    Plugin Support mihai-imagely

    (@mihaiimagely)

    Thanks for your reply @delta-skies!

    It appears that you are using an old shortcode construction for the gallery and respectively an old set of parameters that may affect the overall layout.

    Please edit the page, remove the gallery module/shortcode from it and then generate a new shortcode using either the “Add Gallery” – using Classic Editor or the “NextGen Gallery” module in Gutenberg editor.

    Hope this helps

    Delta Skies

    (@delta-skies)

    Hi @mihaiimagely

    I’ve just created a new page and insert a gallery but with no joy in resolving the problem. The shortcake is now

    <!– wp:tadv/classic-paragraph –>
    [ngg src=”galleries” ids=”1″ display=”basic_thumbnail”]
    <!– /wp:tadv/classic-paragraph –>

    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @delta-skies,

    It seems that the code is ok.
    Just it has the additional wrapping from Gutenberg (You use Gutenberg and then changed our placeholder to a block). Are you using the Classic Editor or the Gutenberg Editor?

    Please, remove NextGen Gallery place holder and include the gallery again, save. If the problem persists, we might need to check for an existing conflict.

    1.- Temporarily deactivate all your plugins except NextGen Gallery.

    2.- Is the problem solved? Then, it was caused by one of your plugins. Please check one by one and find the one causing the problem.

    3.- If the problem is not solved with the deactivation of the plugins, try changing to a standard WordPress theme, it could be a conflict with your current theme.

    Please let us know how it goes.

    Hi @gabyimagely

    Apologies for being so late to respond (I’ve been away and then busy at work).

    I’ve tried 1, 2 & 3 and unfortunately each time the problem is still there.

    I’m really stuck on this one.

    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @delta-skies

    I have rechecked the link, and it seems that this problem is solved.
    http://www.peterbindon.com/kite-bag/single-line-inflatable-kites

    Please, let us know if everything is ok or if we need to keep troubleshooting.
    We are happy to help!

    Hi @gabyimagely

    It’s still looking strange on my iPhone…….

    Screenshot here

    • This reply was modified 3 days, 6 hours ago by  Delta Skies.
    Plugin Support gabyimagely

    (@gabyimagely)

    Hi @delta-skies

    Please, if possible, try to use the option “Override thumbnail settings” on the “Customize display settings” tab. You can increase the size of your thumbnails.

    Keep us posted, we are happy to help!

    hi @gabyimagely

    One of the problems of going that is I’m wanting all thumbnails to be 250 on the longest edge whether they be portrait or landscape. Playing around with the override didn’t seem to solve my problem but also is created issues with the longest edge constraint I’m wanting.

    I’m going to have to create a new gallery on a test site and try from fresh I think

    Plugin Support gabyimagely

    (@gabyimagely)

    Hello @delta-skies

    Please, keep us posted.
    Nevertheless, we may need to check if it’s an existing bug.
    Could you please report this issue as a bug using this form: https://www.imagely.com/report-bug/. Be as specific as possible and let them know Gaby referred you.

    Note: do not forget to include this forum’s link.
    Many thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.