Support » Installing WordPress » Newbie install problem

  • Hi,

    I have just installed WP 2.0.4. I have followed the instructions and uploaded the files to my server. When I run the /wp-admin/install.php file I get the error:
    Error establishing a database connection.

    My ISP is running:
    Windows Server 2003
    PHP 4.4.0
    MySQL 4.0.26

    I can login to mySQL using phpMyAdmin using the same db, username and password as I have set in the wp-config.php file. Yes, I have checked spelling and case (all lower).

    Any ideas ?

    Thanks,
    Murray

Viewing 7 replies - 1 through 7 (of 7 total)
  • Eww…php on windows…thats horrible…anyway…

    are you using ‘localhost’ as the server address? check to see what the IP is or URI and change it to that. Make sure your DB user has the correct permissions. Thats all I can think of right now.

    1. Which server, did you upload? Remote or local server?

    2. Which FTP clients are you using?

    http/1.1404

    What are you using for the location of the db in the wp-config.php file? You maybe that 1% who can’t use localhost for whatever reason.

    I am in the same boat. IIS6 on Win2003, PHP 4.4 and MySQL 4.1.2 (I just downgraded from 5.016). I get the same error. I have tried everything I can imagine. I am specifying the DB Server name (although I should not have to). I added a call to get the DB error – this is what it is:

    Client does not support authentication protocol requested by server; consider upgrading MySQL client

    I am not sure what this means. I have tried several ideas on the MySQL website, but none of them help. I am not sure if this is the PHP client or something in WordPress or what.

    I have installed Toad for MySQL and have no issues connecting to the database from a remote host with it.

    Brad

    I am in the same boat. IIS6 on Win2003, PHP 4.4 and MySQL 4.1.2 (I just downgraded from 5.016). I get the same error. I have tried everything I can imagine. I am specifying the DB Server name (although I should not have to). I added a call to get the DB error – this is what it is:

    Client does not support authentication protocol requested by server; consider upgrading MySQL client

    I am not sure what this means. I have tried several ideas on the MySQL website, but none of them help. I am not sure if this is the PHP client or something in WordPress or what.

    I have installed Toad for MySQL and have no issues connecting to the database from a remote host with it.

    Brad

    I have the same error when setting up WordPress and I am on Dreamhost.

    I am very new to creating a website and to PHP and everything here in general and thought wordpress was a good idea for starting out. Just set up a domain name last week and went through the following setup guide:
    http://www.tamba2.org.uk/wordpress/xampp/

    I checked my settings for MySQL 5.0.21 and everything seems to be in order, just not sure what to do about this error since I am new to the environment. My ftp client is Cute FTP and seems to be working just fine as well. any help would be greatly appreciated. – thank you.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Newbie install problem’ is closed to new replies.