WordPress.org

Support

Support » Plugins and Hacks » [Resolved] New 2.0 version broken!

[Resolved] New 2.0 version broken!

  • Hi dpowney!

    I love your plugin, was very happy to see that a new version came out, however it not working anymore.
    This is the error I get:

    Warning: require(/home/www/test.mediterran.hu/wp-content/plugins/hotspots\tables.php): failed to open stream: No such file or directory in /home/www/test.mediterran.hu/wp-content/plugins/hotspots/hotspots.php on line 14 Fatal error: require(): Failed opening required ‘/home/www/test.mediterran.hu/wp-content/plugins/hotspots\tables.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /home/www/test.mediterran.hu/wp-content/plugins/hotspots/hotspots.php on line 14

    How can I fix it?

    Thanks,
    Tamás

    http://wordpress.org/extend/plugins/hotspots/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author dpowney

    @dpowney

    Hi Tamas,

    Thanks for bringing this to my attention. Can you please download 2.0.1 and try again and let me know if it’s still broken? Thanks a lot!

    Daniel.

    Thanks for the fast reply!

    Now I get the following error message:

    Fatal error: Cannot access self:: when no class scope is active in /home/www/test.mediterran.hu/wp-content/plugins/hotspots/hotspots.php on line 84

    Plugin Author dpowney

    @dpowney

    Hi Tamas,

    Sorry for the inconvenience. My own testing locally did not pick up these issues. Can you please retest with version 2.0.2? Thanks again!

    Daniel.

    Works great now!

    Once again, thanks for the quick response time!

    Tamás

    I’m sorry, but this problem is not solved.

    HotSpots v1.3.1

    Update to 2.0.2 Failed:

    Downloading update from http://downloads.wordpress.org/plugin/hotspots.zip…
    Unpacking the update…
    Installing the latest version…
    Removing the old version of the plugin…
    Plugin updated successfully.
    Plugin failed to reactivate due to a fatal error.
    Parse error: syntax error, unexpected T_FUNCTION in /home/…../public_html/……com/…../wp-content/plugins/hotspots/hotspots.php on line 79

    I suppose it would be all right if I delete the old version and then after that I install a new version of the plugin.

    But then there is a problem with the automatic update.

    Plugin Author dpowney

    @dpowney

    OK, thanks for your help again. We’re getting there…

    You must be using a version of PHO <=5.2 I think. I obviously need to have some more test environments in the future.

    Can you kindly retest for me v2.0.3?
    Daniel

    I tried this on Hostgator. I do not know which version they have now.

    Just a minute. I’ll try with 2.0.3

    On my side, the back-end is still in v2.0.2. No new versions to automatically update.

    Plugin Author dpowney

    @dpowney

    It will show up as available soon.

    Plugin Author dpowney

    @dpowney

    Hi vipteam,

    I need to leave. I will check this forum in a few hours.

    Thanks,
    Daniel.

    Daniel, now it’s all OK

    HotSpots v2.0.2 Update to v2.0.3

    Updating Plugin HotSpots (1/1)
    HotSpots updated successfully. Show Details.
    All updates have been completed.

    Thanks!

    I’m sorry, I did not immediately see it.

    On returning to All Plugins (For me, the plugin was deactivated. Then I clicked on the Activate) shows me the following:

    Plugin could not be activated because it triggered a fatal error.
    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/…../public_html/……com/…../wp-content/plugins/hotspots/hotspots.php on line 82

    Daniel, you mentioned PHP versions. Maybe this can help:

    XAMPP v1.8.1 > PHP: 5.4.7
    Hostgator > PHP: 5.2.17

    The problem relates to Hostgator.

    Now I tried to do the installation and activate the plugin on my local installation (XAMPP). Everything is OK.

    Plugin Author dpowney

    @dpowney

    Hi vipteam,

    Can you try version 2.0.4 on your hostgator hosting. It should fix this new error. Hopefully no more errors now. My local testing was using a later version of PHP. I will try and setup some testing on an older version of PHP in the future to avoid these issues. Thank you.

    Daniel.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] New 2.0 version broken!’ is closed to new replies.