Support » Plugin: Next Active Directory Integration » Network/Multisite WordPress

  • Resolved jordanwierengo

    (@jordanwierengo)


    Hello,

    I am looking at this plugin to be used with our Network/Multisite WordPress. I was looking over the instructions and found:

    “You can enable/disable Next ADI for specific blogs by using the Profiles feature of ADI. It is not possible to activate Next ADI for a site inside a network.”

    I don’t understand “It is not possible to activate Next ADI for a site inside a network.”

    So you can install this plugin on a Network/Multisite but cannot use for site inside the network?

    Can you please confirm this plugin works with a Network of sites?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author schakko

    (@schakko)

    NADI must be installed and activated network-wide and *not* inside a site of a multisite network. You define central NADI profiles which can be used for each site in the network or just for specific sites.

    I am trying to do this, actually, but I am unable to save config info. Clicking the “save” button on the Network Settings area does nothing. I previously had the installed and it worked fine. Ideas?

    @bchalker

    I think you are having the same problems I was having when I was first trying to get this to work. I think you need to change the “Manage Permissions” on the right side. If this option is set to “Blog admin sets this option value.” then the settings you are changing as the Super User are not applied, even when a profile is assigned to a site.

    This makes sense as you would want the blog admin of one of your sites to make the plugin setting changes.

    If you are logged in as the Super User and making changes to a profile and want them to stick, set the Manage Permissions to:

    Deactivated and option value shown.
    Deactivated and option value not shown.
    Input field is invisible.

    Please let me know if this fixes your issue.

    Thanks for taking time to reply Jordan. Unfortunately, I don’t even have the dropdown populated.

    See the screenshot here: Admin funky

    • This reply was modified 2 years, 9 months ago by  bchalker.

    bchalker,

    The screenshot is not working.

    Plugin Author schakko

    (@schakko)

    @bchalker: Please check for any JavaScript errors by pressing F12 and select “Console”. It’s likely that there are old JavaScript files in your cache. Just flush the cache and try it again.

    Apologies Jordan (@jordanwierengo). Just returned from vacation…wasn’t ignoring this.

    Admin with odd ui:
    https://drive.google.com/open?id=0B3jAmyuxFw2laUhxNjR3SVUwams

    Thx @schakko – I cleared and it actually looks to be an error with creating the JSON object (see attached screenshots). I am unable to create a profile.

    https://drive.google.com/open?id=0B3jAmyuxFw2lSXh6WGctM1ZrYnM
    https://drive.google.com/open?id=0B3jAmyuxFw2lSzZNdjd3aXBKWDQ

    Plugin Author schakko

    (@schakko)

    @bchalker Please click on the “Network” tab and click on the HTTP/JSON response. There is an invalid JSON response which led to not being able to parse the response.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Network/Multisite WordPress’ is closed to new replies.