Support » Plugin: Raw HTML » nbsp

  • Hi:
    I have this problem on a WP test site and it also occurred in the demo for this plugin. We’re transitioning from a non-WP proprietary site to a WP site and we have 1000’s of articles that have to be imported. The import/conversion by the developers did not go too well, so I’ve been fixing it.

    Some of the articles had “paragraphs” made with div tags, and the space between paragraphs was <div> </div> (the editor for the site did this automatically if creating within the site). The article imports to WP OK, but on saving it in the editor WP helpfully removes the   but leaves the now empty div wrapper. So there is no space between the paragraphs.

    The plugin, with all the checkboxes chosen does not prevent this from happening, but wrapping the tags within [raw] does work. But I thought it would work just with the boxes checked. What’s going on? What filter in WP is doing this and WHY????
    Thanks
    Alex

Viewing 1 replies (of 1 total)
  • Plugin Author Janis Elsts

    (@whiteshadow)

    The checkboxes only apply to filters that WordPress runs when the post is displayed in the front-end. They don’t affect the editor at all.

    I’m not sure which filters affect the editor content. Try turning off this option in Settings -> Writing: “WordPress should correct invalidly nested XHTML automatically”.

Viewing 1 replies (of 1 total)
  • The topic ‘nbsp’ is closed to new replies.