Support » Plugin: Elementor Page Builder » Namespace error

  • Resolved harbours

    (@harbours)


    Everything was working fine last night but today when I try to edit a page with Elementor I get stuck on the gray loading page. I’ve tried enabling safe mode, disabling all other plugins, using the default WordPress theme, reinstalling Elementor with no luck. I’ve even tried installing a fresh copy of WP in a different directory and have the same problem.

    This error comes up in the console:

    NamespaceError: An attempt was made to create or change an object in a way which is incorrect with regard to namespaces editor.min.js:32

    In safe mode, I get the same as above plus:

    TypeError: i is undefined

Viewing 4 replies - 1 through 4 (of 4 total)
  • cavalierlife

    (@cavalierlife)

    Please see the suggestions at https://docs.elementor.com/article/184-cant-edit-with-elementor#grayendless

    If the issue persists, please share the site URL so we can take a closer look.

    harbours

    (@harbours)

    Thanks for the reply @cavalierlife. I’ve tried those suggestions. Would it be possible to troubleshoot if I block out my domain name? It’s only Elementor that doesn’t work; the site itself loads fine and editing the normal way works fine. As I mentioned before, Elementor was working last night but when I tried to work on it today it wouldn’t load.

    This is the System Info log, with my domain name replaced with **domain**:

    == Server Environment ==
    	Operating System: Linux
    	Software: Apache
    	MySQL version: Source distribution v5.7.26-29
    	PHP Version: 7.1.30
    	PHP Max Input Vars: 3000
    	PHP Max Post Size: 128M
    	GD Installed: Yes
    	ZIP Installed: Yes
    	Write Permissions: All right
    	Elementor Library: Connected
    
    == WordPress Environment ==
    	Version: 5.2.2
    	Site URL: **domain**/test
    	Home URL: **domain**/test
    	WP Multisite: No
    	Max Upload Size: 128 MB
    	Memory limit: 768M
    	Permalink Structure: Plain
    	Language: en-US
    	Timezone: 0
    	Debug Mode: Inactive
    
    == Theme ==
    	Name: Twenty Nineteen
    	Version: 1.4
    	Author: the WordPress team
    	Child Theme: No
    
    == User ==
    	Role: administrator
    	WP Profile lang: en_US
    	User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:64.0) Gecko/20100101 Firefox/64.0
    
    == Active Plugins ==
    	Elementor
    		Version: 2.6.8
    		Author: Elementor.com
    
    == Log ==
    	: 
    JS: showing 1 of 1JS: 2019-08-12 21:03:54 [error X 1][https://**domain**/test/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.6.8:32:0] An attempt was made to create or change an object in a way which is incorrect with regard to namespaces 

    And this is the error log from the console:

    NamespaceError: An attempt was made to create or change an object in a way which is incorrect with regard to namespaces editor.min.js:32
    
    ​_createSVGPreset https://**domain**/test/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.6.8:32
        getPresetSVG https://**domain**/test/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.6.8:32
        Backbone 9
        render self-hosted:1001
        onRender https://**domain**/test/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.6.8:32
        Backbone 3
        render self-hosted:1001
        Backbone 2
        onPreviewLoaded https://**domain**/test/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.6.8:7
        onPreviewLoaded self-hosted:1003
        Backbone 2
    harbours

    (@harbours)

    Just an update for everyone else having this issue: a user in another thread seems to have figured out the problem.

    A temporary fix for those on Siteground: Go to HTTPS Enforce and disable External Links Rewrite. The Elementor editor should load now. You can always go back and enable it again once you’re done editing.

    I still don’t understand why this suddenly broke Elementor since it’s been working fine with External Links Rewrite enabled all this time but hopefully the devs will address it soon.

    • This reply was modified 4 months ago by harbours.
    • This reply was modified 4 months ago by harbours.
    Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    If you force HTTPS from the SG Optimizer plugin, you don’t need to do it from Site Tools. Disable the rewrite external links and leave only the plugin to do its magic 🙂 In an upcoming Elementor update I was promissed they will address this but GENERALLY it is not a good thing to force HTTPS from two different places.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Namespace error’ is closed to new replies.