Support » Networking WordPress » Multisite links broken

  • Resolved prettycoolmania

    (@prettycoolmania)


    Hello all,

    I have a few multi sites and it’s not working for some time now. I am looking into this and saw a few forums but nothing seems to be helpful.

    My htaccess code:

    RewriteEngine On
    RewriteBase /blogs/
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)$ $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    Please let me know what I am missing and needed to do to get these multi site links operational again. Thank you !

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Justin Greer

    (@justingreerbbi)

    Forum Moderator

    You will have to provide a little more information and what links are not working and so on.

    Direct access to the sites?
    Actual links in the content?

    I’ll try to explain as best as possible. Say we got a parent website which is working just fine and that includes all the website functionality like comments, post or anything which a website can have it directly goes to the right section when you click on the links.

    Under the parent website I got 5 child sites and none of them works. For eg, when i click on comments it says “File not found” and i get the same error when i click on anything within the child site. Plus, the CSS format is all messed up as the website items like comments, users, etc are all showing one below the other and doesn’t loo like a website.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Can you verify that AllowOverride is set to either “All” or “Options All” on your server’s httpd.conf?

    Well for security reasons we have it set to NONE but the setting on vhost conf is set to ALL. I am running short of ideas and bumping onto the wall on this issue. This is a development site which i am working on to get fixed before it gets to Production site

    I have placed the logs below if that sheds light

    [Wed Dec 03 13:57:43.519929 2014] [proxy_fcgi:error] [pid 31093:tid 139638555526912] [client xx.xxx.xx.xx:xxxxx] AH01071: Got error ‘Primary script unknown\n’
    [Wed Dec 03 13:57:43.718793 2014] [proxy_fcgi:error] [pid 31092:tid 139638463207168] [client xx.xxx.xx.xx: xxxxx] AH01071: Got error ‘Primary script unknown\n’, referer: http://xxxxx/wp-admin/
    [Wed Dec 03 13:57:43.723899 2014] [proxy_fcgi:error] [pid 31092:tid 139638421243648] [client xx.xxx.xx.xx: xxxxx] AH01071: Got error ‘Primary script unknown\n’, referer: http://xxxxx/wp-admin/
    [Wed Dec 03 13:57:43.724227 2014] [proxy_fcgi:error] [pid 31092:tid 139638471599872] [client xx.xxx.xx.xx:xxxxx] AH01071: Got error ‘Primary script unknown\n’, referer: http://xxxxx/wp-admin/
    [Wed Dec 03 14:11:00.531110 2014] [proxy_fcgi:error] [pid 31092:tid 139638488385280] [client xx.xxx.xx.xx: xxxxx] AH01071: Got error ‘Primary script unknown\n’
    [Wed Dec 03 14:11:00.752446 2014] [proxy_fcgi:error] [pid 31092:tid 139638479992576] [client xx.xxx.xx.xx: xxxxx] AH01071: Got error ‘Primary script unknown\n’, referer: http://xxxxx/wp-admin/
    [Wed Dec 03 14:11:00.755576 2014] [proxy_fcgi:error] [pid 31092:tid 139638496777984] [client xx.xxx.xx.xx:xxxxx] AH01071: Got error ‘Primary script unknown\n’, referer: http://xxxxx/wp-admin/
    [Wed Dec 03 14:11:00.759567 2014] [proxy_fcgi:error] [pid 31092:tid 139638438029056] [client xx.xxx.xx.xx: xxxxx] AH01071: Got error ‘Primary script unknown\n’, referer: http://xxxxx/wp-admin/
    [Wed Dec 03 14:16:22.284071 2014] [proxy_fcgi:error] [pid 31093:tid 139638471599872] [client xx.xxx.xx.xx: xxxxx] AH01071: Got error ‘Primary script unknown\n’
    [Wed Dec 03 14:16:22.540089 2014] [proxy_fcgi:error] [pid 31092:tid 139638521956096] [client xx.xxx.xx.xx:xxxxx] AH01071: Got error ‘Primary script unknown\n’, referer: http://xxxxx/wp-admin/
    [Wed Dec 03 14:16:22.563988 2014] [proxy_fcgi:error] [pid 31092:tid 139638580705024] [client xx.xxx.xx.xx:xxxxx] AH01071: Got error ‘Primary script unknown\n’, referer: http:// xxxxx /wp-admin/
    [Wed Dec 03 14:16:22.567613 2014] [proxy_fcgi:error] [pid 31093:tid 139638580705024] [client xx.xxx.xx.xx:xxxxx] AH01071: Got error ‘Primary script unknown\n’, referer: http:// xxxxx /wp-admin/
    [Wed Dec 03 14:16:24.962022 2014] [proxy_fcgi:error] [pid 31093:tid 139638505170688] [client xx.xxx.xx.xx:xxxxx] AH01071: Got error ‘Primary script unknown\n’, referer: http:// xxxxx /wp-admin/

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Well for security reasons we have it set to NONE but the setting on vhost conf is set to ALL.

    Can you change vhost to “Options All” ? Sometimes it matters….

    proxy_fcgi:error is a new one on me though.

    Maybe related to http://serverfault.com/questions/450628/apache-2-4-php-fpm-proxypassmatch

    Made the change and no change as it’s still the same result 🙁

    clicking on Dashboard i can see the links one below the other but when i click on them it says “File not Found” SOO WIERD

    Moderator Justin Greer

    (@justingreerbbi)

    Forum Moderator

    @prettycoolmania

    Sound like you may be on a dedicated server of sorts. Is the server by chance running Fast CGI Process Manager?

    The error logs you provided suggest that the ProxyPass settings is not setup correctly or at all for subdirectories. Something like the following if your VirtualHost settings for each of your domains.

    <LocationMatch "^(.*\.php)$">
      ProxyPass fcgi://127.0.0.1:9000/siteroot
    </LocationMatch>

    I had a similar issue years ago when simply trying to have multiple domains on the same directory. Might not be a solution to your issue but may suggest a possible cause of your issues if you have not checked that yet.

    Thanks for the reply justingreerbbi

    This is what i have

    ProxyPassMatch ^/(.*\.php(/.*)?)$fcgi://127.0.0.1:9000/srv/vhosts/blogs.example.com/htdocs/$1
    #DirectoryIndex index.php
    Moderator Justin Greer

    (@justingreerbbi)

    Forum Moderator

    I am not an expert at this by any means so correct me where it fits. Does it matter if the ProxyPass is not wrapped with the LocationMatch tag? Have you tried it not using shorthand (what I am assuming you have)? Also, I don’t know if you have DirectoryIndex commented out of purpose or not but does that have any effect? You mentioned that the error is “File Not Found”. This indicate a that the server may not really know to look for the correct file types.

    I am recalling off memory from years ago after watching a IT guy fix our issues that were similar to yours. So what I am saying may not bear any advice you may not already know.

    Thanks Justingreerbbi, i finally figured what was the issue so thought of sharing my fix here

    Created symbolic links for the multi-site subfolders
    # cd /path/to/docroot
    # ln -s health .
    # ln -s computer-science .
    # ln -s other-multisite .

    Thanks for all your help guys, appreciate it !

    Haoxian

    (@lonelicloud)

    Hi, prettycoolmania,

    Here is another fix you can give it a try.

    Add following directive,

    ProxyPassMatch ^/([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes)/.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/srv/vhosts/blogs.example.com/htdocs/$2

    before your,

    ProxyPassMatch ^/(.*\.php(/.*)?)$fcgi://127.0.0.1:9000/srv/vhosts/blogs.example.com/htdocs/$1

    But this might not be perfect 😛

    reference: http://cnzhx.net/blog/apache-php-fpm-and-wordpress-multisite/

    Google translation: https://translate.google.com/translate?hl=en&sl=zh-CN&tl=en&u=http%3A%2F%2Fcnzhx.net%2Fblog%2Fapache-php-fpm-and-wordpress-multisite%2F

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Multisite links broken’ is closed to new replies.