Support » Networking WordPress » Multisite cant login to super admin

  • Resolved fearRacious

    (@fearracious)


    Hey guys,

    I have switched my website from a 209.105.244.10 to http://www.drheatherlariviere.com/ but and it worked good..Just when I login at firefox it wont let me instead go to the homepage.But in Chrome it worked and it lets me login.But when I try to go to the super admin to add plugins it wont let me login..

    Can anyone help me??

    Thank you

Viewing 15 replies - 1 through 15 (of 42 total)
  • Hey, Thank you for the reply..I actually done that..That was my first step when I was switching it.It worked now and I can also get to the admin BUT not in the network admin.It just redirect me to a login form and I cant login back…

    here is my .htaccess files

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    and here is the wp-config

    /* Multisite */
    define(‘WP_ALLOW_MULTISITE’, true);
    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, false);
    define(‘DOMAIN_CURRENT_SITE’, ‘drheatherlariviere.com’);
    define(‘PATH_CURRENT_SITE’, ‘/’);
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOG_ID_CURRENT_SITE’, 1);

    define(‘ADMIN_COOKIE_PATH’, ‘/’);
    define(‘COOKIE_DOMAIN’, ”);
    define(‘COOKIEPATH’, ”);
    define(‘SITECOOKIEPATH’, ”);

    /* That’s all, stop editing! Happy blogging. */

    Are you absolutely sure you’re logged in as the super admin?

    Go into wp_sitemeta and look for site_admins.

    In there you will see something like this: a:1:{i:0;s:7:"Ipstenu";}

    If your userID is ‘fearRacious’ then it would be a:1:{i:0;s:11:"fearRacious";}

    yes…

    here is my site_admins is a:1:{i:0;s:12:”drheater5432″;}

    Do I have to change on the site_admins??

    Also,when I changed my permalink.The other links are not working so now im using the default permalink..

    Am I doing something wrong on the Database and wp-config and htaccess??

    Do I have to change on the site_admins??

    No. That wasn’t the point. The point was to VERIFY you were the admin. If you’re logged in as drheater5432 you should be fine.

    Try deleting all your cookies for the old and new blog URL.

    Try deleting all your cookies for the old and new blog URL.

    Wait,how to do that..I did with my ccleaner and clean my pc and browser..But didnt work..

    I did try clearing my browser cookies at chrome but going to super admin It wont log me in..When I do like http://www.drheatherlariviere.com/wp-admin and put the username and password it worked,and I can log in successfully..

    When I try clicking to the super admin it just log me out and need to enter the username and password again..

    Is there something wrong on the installation??

    Is there any wrong with my htaccess or wp-config??also my permalink not working when I set to default.Now I have to put it at default..

    Anyone???

    I was testing the link that I have when I login to the http://www.drheatherlariviere.com/wp-admin it gives me this link
    (http://www.drheatherlariviere.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.drheatherlariviere.com%2Fwp-admin%2Fnetwork%2F&reauth=1)

    And when I try to go to super admin this is the link it show (http://www.drheatherlariviere.com/wp-login.php?redirect_to=http%3A%2F%2Fdrheatherlariviere.com%2Fwp-admin%2F&reauth=1)

    and I notice that in the http%3A%2F%2Fdrheatherlariviere.com theres no www. so I added it and I finally login to the wordpress network admin..

    So,if Im not wrong that might be the problem so how can I get that fixed??

    thank you.

    Be calm and don’t bump your posts needlessly.

    The forums are staffed 100% by volunteers, all of whom have jobs. If you need to have something fixed that fast, you hire someone from jobs.wordpress.net – otherwise, you wait and hope someone sees this and can fix it.

    Interesting that your site is using www when the wp-config clearly says it shouldn’t be:

    define('DOMAIN_CURRENT_SITE', 'drheatherlariviere.com');

    Does your webhost force in the www? You may need to search/replace and add that in, though I’d hate to do that :/ Basically something on your server is forcing in www. You may want to ask your host about it.

    Thanks Ipstenu..

    By you mean of search and replace..Do you mean the wordpress plugin that I have to search and replace or to the Database..Or should I go to my database and look for that??

    “Does your webhost force in the www? You may need to search/replace and add that in, though I’d hate to do that :/ Basically something on your server is forcing in www. You may want to ask your host about it.”

    I dont get you on this…So, I should ask our hosting provider if they require a http://www.??

    When you moved your site, did you search for the IP and replace with www. drheatherlariviere.com or JUST drheatherlariviere.com?

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘Multisite cant login to super admin’ is closed to new replies.