WordPress.org

Support

Support » Plugins and Hacks » Multiple errors in plugin with debug on.

Multiple errors in plugin with debug on.

  • I have found several errors in the plugin with wp_debug on. I would be happy to resolve them quickly and send you the revised copy if you dont mind adding me as a contributor.

    Here are the errors

    Notice: Use of undefined constant ADDTHIS_SSI_PRODUCT_CODE - assumed 'ADDTHIS_SSI_PRODUCT_CODE' in F:\_localhost\www\em\wp-content\plugins\addthis-social-sign-in\addthis_social_sign_in.php on line 12
    Notice: Use of undefined constant ADDTHIS_SSI_AT_VERSION - assumed 'ADDTHIS_SSI_AT_VERSION' in F:\_localhost\www\em\wp-content\plugins\addthis-social-sign-in\addthis_social_sign_in.php on line 13
    Notice: wp_enqueue_script was called <strong>incorrectly</strong>. Scripts and styles should not be registered or enqueued until the <code>wp_enqueue_scripts</code>, <code>admin_enqueue_scripts</code>, or <code>login_enqueue_scripts</code> hooks. Please see <a href="http://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress</a> for more information. (This message was added in version 3.3.) in F:\_localhost\www\em\wp-includes\functions.php on line 3060
    Notice: Undefined index: page in F:\_localhost\www\em\wp-content\plugins\addthis-social-sign-in\addthis_social_sign_in.php on line 52
    Notice: Undefined index: action in F:\_localhost\www\em\wp-content\plugins\addthis-social-sign-in\addthis_social_sign_in.php on line 158
    Notice: wp_enqueue_style was called <strong>incorrectly</strong>. Scripts and styles should not be registered or enqueued until the <code>wp_enqueue_scripts</code>, <code>admin_enqueue_scripts</code>, or <code>login_enqueue_scripts</code> hooks. Please see <a href="http://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress</a> for more information. (This message was added in version 3.3.) in F:\_localhost\www\em\wp-includes\functions.php on line 3060

    http://wordpress.org/plugins/addthis-social-sign-in/

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Multiple errors in plugin with debug on.’ is closed to new replies.