Support » Fixing WordPress » Moved Hosts, Image Upload problem

  • Resolved passionforhealth


    I recently switch to Midphase from another host and now can’t upload images. I’ve switched permissions to 777 but it seems to be a bigger problem than just permissions.

    I switched all files, folders and the database over completely ‘as is’.

    Apart from needing to rename the db_host in wp-config.php all seemed fine. Then I noticed the error messages on the Edit Post section. They were in this form:


    Warning: file_exists() [function.file-exists]: open_basedir restriction in
    is not within the allowed path(s):
    (/home/passrid3:/usr/lib/php:/usr/local/lib/php:/tmp) in
    /home/passrid3/public_html/wp-admin/inline-uploading.php on line 224


    I researched this here:

    and passed it on to Midphase (my new host). The error messages now don’t appear on the Edit Post page but I still can’t upload new images. I get this error:


    The uploaded file could not be moved to .


    If I browse the wp_postmeta table, I can see that images that were uploaded while on the old server have the absolute path saved as /home/httpd/vhosts/……

    and I’m aware that the absolute path on the new server is /home/passrid3/public_html……

    … but how do I get WordPress to use that path when saving new uploaded images (if in fact that’s the problem)?

    Midphase (the hosts) are telling me to reinstall WordPress, which is massively less than desirable – we don’t want to lose the posts we’ve already made.

    We’re using WordPress v2.0.4

    Your help would be greatly appreciated!

Viewing 1 replies (of 1 total)
  • Just an update on the problem above. This is now resolved! I think there were probably two seperate problems here. The first was the oopen_basedir problem which Midphase support solved for me.

    Next, the error message:


    The uploaded file could not be moved to .


    was probably an entirely seperate problem and turned out to be a simple permissions error. I thought I had already tried changing permissions via my FTP package. In any case, administering permissions through Midphase’s cpanel did the trick.

    Problem solved! Hope this helps anyone searching for a solution to the same problem 🙂

Viewing 1 replies (of 1 total)
  • The topic ‘Moved Hosts, Image Upload problem’ is closed to new replies.