Support » Plugin: Alex Player » Mobile Playback

  • Resolved sasharples

    (@sasharples)


    Hello, this is a great plugin you have developed, perfect for hosting audio files on my website.

    However, none of the buttons work on my mobile device (iphone)

    • This topic was modified 9 months, 2 weeks ago by sasharples.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author iamzhirik

    (@iamzhirik)

    I’ve just tested in iPhone simulator in Google Chrome (cause I don’t have iPhone), and the buttons works fine there. If you send me the direct link to the page where it does not work than I can tell you what the problem could be.

    https://coalescesound.com/beatstore/

    I am using Jetengine listings to display each instrumental so I think this could be causing the problem?

    Plugin Author iamzhirik

    (@iamzhirik)

    Player on your website works fine on my iPhone emulator:
    http://images.x10.name/ap-test1.jpg

    At the moment I don’t know how to reproduce your bug, cause everything is working fine even on your website. Also I’ve tested on my Android phone and it also works fine.

    I can confirm that I could not start a player created by [UIPlayButton] on my iPhone 8Plus. I do not own any other mobile device, so I could not cross check that.

    I assume that this has something to do with the touch event not being recognized.

    Would be great if we could get that fixed, otherwise this plugin is useless on mobile phones. Which would be a real pitty.

    Plugin Author iamzhirik

    (@iamzhirik)

    Just tested the UIPlayButton in iPhone emulator, it works for me on iPhone 8Plus, but…

    On all the iPhone devices audio playback can be started only when audio is fully loaded (On other devices it can be started even if audio is partially loaded, but on iPhone does not). Generally it takes around few seconds to load whole the audio, but if you have very big audio file or slow internet connection that it can take more time to load it.

    You tell that touch event is not recognized, but I think that the audio was not loaded yet and can’t be started at the moment. Possibly you can start the playback, but after you wait few or more seconds (depending on how much big your audio file is)

    What size of the audio file do you have, is it 5 MB or much more? I think you have really big audio file, am I right?

    First of all: Thanks for the reply.

    I checked the original audio file, yes it was 5.070 KB.

    Next, I tried it with another audio file that was only 2 MB in size. That lets me start the player, but once stopped, I could not restart it again.

    After that I tried it with two different Players on a page, both with a separate ID and with mp3 around 2MB size. Same result. I could start them (despite the fact that they are running simultaniously, see my other post), stop them once, but could not restart them again.

    This behaviour does not change, even if I wait several minutes.

    Great plugin so far, but has some little flaws. And I really, really like the vizualisation. Perfect for my band’s page. And my two cents: 5mb is not that big for a nice mp3 file these days. At least I think so.

    Plugin Author iamzhirik

    (@iamzhirik)

    Possibly we need to share some links between each other and test the things around this bug.
    Can you contact me though the contact form?
    http://alex.player.x10.name/contact/

    Will do so, but not before the end of next week. I have to go to the hospital for a few days. But after that I am more than willing to help you iron out these little issues.

    Plugin Author iamzhirik

    (@iamzhirik)

    Okay, no problem

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.