Support » Plugin: W3 Total Cache » Mixed content on https pages when setting Page cache method: Disk: Enhanced

  • Is it just me? I noticed that when setting Page cache method = Disk: Enhanced, the pages accessed via https throw “Mixed content” security errors/warnings. No such errors when setting Page cache method = Disk: Basic.

    I have W3 Total Cache plugin Version 0.9.5.1, WP 4.7.

    To reproduce the error: in W3 Total Cache
    – Toggle all caching types off (at once), then
    – Toggle Page Cache: Enable, set Page cache method = Disk: Enhanced
    – Save all settings (now “Page Cache” should be the only enabled option),
    – Purge all caches.
    – Then from an incognito Chrome window visit a non-secure (http) page, and then visit the same page as secure (https). Observe “mixed content” security errors/warnings (the security icon in Chrome is an exclamation’!’ rather than a green padlock).

    To reproduce absence of “mixed content” when setting Page cache method = Disk: Basic: in W3 Total Cache
    – Set Page cache method = Disk: Basic
    – Save all settings (“Page Cache” should still be the only enabled option),
    – Purge all caches.
    – Then from an incognito Chrome window visit a non-secure (http) page, and then visit the same page as secure (https). Observe absence of “mixed content” security errors/warnings (the security icon in Chrome is a green padlock).

    • This topic was modified 1 year, 9 months ago by  ymf. Reason: typos
  • The topic ‘Mixed content on https pages when setting Page cache method: Disk: Enhanced’ is closed to new replies.